Overlaid images over table cell (moz-float-edge, float, overflow)

RESOLVED FIXED in mozilla1.9beta4

Status

()

P2
normal
RESOLVED FIXED
17 years ago
11 years ago

People

(Reporter: eennjp, Assigned: dbaron)

Tracking

({testcase})

Trunk
mozilla1.9beta4
x86
Linux
testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020222
BuildID:    2002022208

The image below the second bullet-point overlays the 'Article Info' block, where
I assume it should not.

This bug is still present in a completely-saved version.

Reproducible: Always

Comment 1

17 years ago
Confirming issue in the Feb 25th os x build.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Future

Updated

17 years ago
Keywords: testcase

Comment 2

17 years ago
Created attachment 82569 [details]
Reduced test that shows this problem

Comment 3

17 years ago
This test case contains a nested table (align=right), a unclosed LI, then a BR
element. If you close the LI before the BR element. The image appears below the
right aligned table instead of overlapping it.

Comment 4

17 years ago
Taking.
Assignee: attinasi → waterson
Summary: Overlaid images over table cell → [FLOAT] Overlaid images over table cell
Target Milestone: Future → ---

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Updated

16 years ago
Component: Layout → Layout: Floats
Summary: [FLOAT] Overlaid images over table cell → Overlaid images over table cell
The image is 525px wide.  The floating table is 155px wide.  The table
containing the whole mess is 610px wide.  So you end up with 70px of overlap, of
course.  The reason the <li> is relevant is that it uses moz-float-edge instead
of just flowing around the float.... and the image overflows the <li>.
Summary: Overlaid images over table cell → Overlaid images over table cell (moz-float-edge, float, overflow)
Assignee: waterson → nobody
Status: ASSIGNED → NEW
QA Contact: chrispetersen → layout.floats
Fixed by checkin of bug 413840.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Depends on: 143162, 413840
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.