Last Comment Bug 127879 - No Search Capability when Outlook in OCL mode
: No Search Capability when Outlook in OCL mode
Status: RESOLVED EXPIRED
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Address Book & Contacts (show other bugs)
: Trunk
: x86 Windows 2000
-- normal (vote)
: ---
Assigned To: mail
:
:
Mentors:
Depends on: 111968 118119
Blocks: 213274
  Show dependency treegraph
 
Reported: 2002-02-26 09:50 PST by John Marmion
Modified: 2010-04-28 12:58 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image John Marmion 2002-02-26 09:50:34 PST
Outlook can be configured in Internet-only mode with a local Address Book (OIL)
or as a Corporate/WorkGroup Client using a local Address Book (OCL). Mozilla is
capable of accessing these Outlook Address Books dynamically. In the latter
case, no data is returned using the quick search or advanced search in Mozilla.
This problem is inherent in the MAPI implementation of Outlook in this mode. The
Search capabilities of Outlook itself in this mode are very limited in
comparison to the OIL mode. Nevertheless, Mozilla can employ the proxy search
capabilities to return Data.
Comment 1 User image John Marmion 2002-04-05 07:55:11 PST
I recently had another look at this. MAPI uses a Restriction() to return data.
The error code MAPI_E_TOO_COMPLEX (0x80040117) appears to be always returned no
matter  how simple I create a query. The Outlook UI appears to support a very
limited query capability using the DisplayName attribute and the "contains"
operator. Nevertheless, I have been unable to implement this limited search
capability.
Comment 2 User image (not reading, please use seth@sspitzer.org instead) 2003-05-08 09:42:14 PDT
mass re-assign.
Comment 3 User image Robert Kaiser 2009-06-14 14:39:57 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 4 User image Robert Kaiser 2010-04-28 12:58:25 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420

Note You need to log in before you can comment on or make changes to this bug.