Addon corrupt on Firefox 47

RESOLVED DUPLICATE of bug 1253565

Status

()

--
major
RESOLVED DUPLICATE of bug 1253565
3 years ago
2 years ago

People

(Reporter: shinpachinaide, Unassigned)

Tracking

({regression})

47 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

11.67 KB, application/x-xpinstall
Details
(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

1. Open addon page
2. Click install addon
3. Got error "The add-on downloaded from this site could not be installed because it appears to be corrupt."


Actual results:

Hi, I'm the author of this addon.
https://addons.mozilla.org/en-US/firefox/addon/server-view/

Someone reported to me the icon does not appear in Firefox 47, so I upgraded to Firefox 47 to test. The icon does not appear there.

The latest version is WebExtension. So I then tried the older version which was made using Addon SDK. The icon appears again.

After that I tried installing again the latest version,  and I got this error
"The add-on downloaded from this site could not be installed because it appears to be corrupt."

Confused by this. I tried to downgrade to Firefox 46. The addon and install works there. I'm really confused what's changed in Firefox 47? Should I go back to Addon SDK?

I've tried creating new profile, but got same result.


Expected results:

Install success and addon works as intended

Comment 2

3 years ago
WFM with FF47 32 bits on Win 7. I see the add-on icon in the toolbar and server is displayed in the tooltip when visiting a website. Maybe an issue with 64b version.

Comment 3

3 years ago
Mmmh, I didn't see you disabled version 0.0.3 of you add-on on AMO, it's 0.0.2 now, so I guess it works due to downgrading.

Could you provide the latest version of you add-on, please.
Flags: needinfo?(shinpachinaide)

Updated

3 years ago
Component: Untriaged → Extension Compatibility
(Reporter)

Comment 4

3 years ago
Created attachment 8761912 [details]
server_view-0.0.3-fx.xpi

Sorry I don't know the disabled version is not in the version list.
Here's the xpi
I can confirm this is broken in 47.0. It works fine in 46.0.1 and 48.0b1

1465551795199	addons.webextension.<unknown>	ERROR	Loading extension 'null': Reading manifest: Error processing background: Error processing background: Unexpected property "persistent"
 Log.jsm:751:0

Stacktrace:
App_append()
 Log.jsm:751
Logger.prototype.log()
 Log.jsm:388
Logger.prototype.error()
 Log.jsm:396
packagingError()
 Extension.jsm:545
manifestError()
 Extension.jsm:539
readManifest/<()
 Extension.jsm:668

1465551795201	addons.xpi	WARN	Download of https://addons.mozilla.org/firefox/downloads/latest/server-view/addon-674086-latest.xpi?src=dp-btn-primary failed: Error: Extension is invalid (resource://gre/modules/addons/XPIProvider.jsm:875:11) JS Stack trace: loadManifestFromWebManifest<@XPIProvider.jsm:875:11 < TaskImpl_run@Task.jsm:319:40 < Handler.prototype.process@Promise-backend.js:937:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:816:7 < this.PromiseWalker.scheduleWalkerLoop/<@Promise-backend.js:750:11

The manifest file contains the following block:

	"background": {
		"scripts": ["background.js"],
		"persistent": false
	}

The persistent property looks like being the issue.

Kris or Bill, is this bad enough to backport and include the fix in a potential chemspill?
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(wmccloskey)
Flags: needinfo?(shinpachinaide)
Flags: needinfo?(kmaglione+bmo)
Keywords: regression

Comment 6

3 years ago
It regressed by Bug 1225715:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=584870f1cbc5d060a57e147ce249f736956e2b62&tochange=b2a3dc4b161fdfac6db78cc5bbfb1f53a383b65a

It has been fixed by Bug 1253565:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5cfc10c14aaea2a449f74dcbb366179a45442dd6&tochange=fd250005129607b930f96c843c6b36710abbf692


I tested myself, it's already fixed in 48/49/50. So I doubt there is something to do, in addition, WebExtensions API is meant to be stable with the release of 48. Maybe the author can downgrade his extension to 0.0.2 on AMO and wait for updating it to 0.0.3 after the release of FF48 in 2016-08-02.
Blocks: 1225715
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253565
Agreed. This is already fixed in 48. We won't be uplifting it to 47.
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(wmccloskey)

Updated

2 years ago
Duplicate of this bug: 1281945
You need to log in before you can comment on or make changes to this bug.