SELECTED option in OPTION tag ignored

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Layout: Form Controls
--
minor
VERIFIED DUPLICATE of bug 46845
16 years ago
13 years ago

People

(Reporter: Avleen Vig, Assigned: rods (gone))

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
In forms that use <OPTION SELECTED VALUE="Foo">, the 'SELECTED' option is
ignored and the top item in the list of <OPTION>'s is selected by default.
This can (and does in my case) break sites that depend on the chosen SELECTED
option being selected by default.

The option can be selected manually, but that breaks the use of SELECTED.
(Reporter)

Comment 1

16 years ago
This works:
<option selected value="Unassigned">Unassigned</option>

This does not:
<option value="Unassigned" selected>Unassigned</option>
Created attachment 71593 [details]
testcase
worksforme, linux build 2002-02-24-06.  See attached testcase -- both comboboxes
have the right thing selected.

Avleen, what build are you using?  Is there an HTML page that demonstrates the
problem?
(Reporter)

Comment 4

16 years ago
I don't know how to explain this :-/

Even the test cases I had set up appear to work now :-/

But I certainly wasn't just seeing things!
> I don't know how to explain this :-/

'Twas those damn daemons I tell you!

<ahem>

;-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
I found a way to replecate the problem - this prompted me to change the severity
to 'minor'.

Open a page with a form, where 'selected' is not used.
Now, edit the source so that 'selected' IS used, and click reload.
The menu isn't updated to used the new 'selected' :-)
Severity: major → minor
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
That's because form values persist across reload (bug 46845).  Try shift-reload.
(Reporter)

Comment 8

16 years ago
hmmmm I might be wrong.. if I am please correct me!
Isn't the point of 'reload', to check if the page has been updated, and if so
display the new page - and not keep old values around?

If so, I don't see why there is a need for a Shift-Reload.

I understand that it's used to tell systems to ignore the cache and fetch from
the server, but if 'reload' is fetching from the server, why isn't it updating
the screen? :-)
Because of bug 46845

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.