password manager notification access key

RESOLVED FIXED in Firefox 53

Status

()

defect
P3
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: microrffr, Assigned: past)

Tracking

45 Branch
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

(Whiteboard: [passwords:capture-UI] [fxprivacy])

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Android 6.0.1; Mobile; rv:50.0) Gecko/50.0 Firefox/50.0
Build ID: 20160608030219

Steps to reproduce:

log in to something
notification shows up about remembering password
press alt+r


Actual results:

focuses drop down arrow next to "Remember" button


Expected results:

activates "Remember" button
Component: Untriaged → Password Manager
Product: Firefox → Toolkit
Whiteboard: [passwords:capture-UI]
This will likely be fixed by the redesign of the remember password prompt. Marking for fxprivacy so we can decide what to do with this bug.
Priority: -- → P3
Whiteboard: [passwords:capture-UI] → [passwords:capture-UI] [fxprivacy][triage]
Depends on: 1267604
Whiteboard: [passwords:capture-UI] [fxprivacy][triage] → [passwords:capture-UI] [fxprivacy]
Unfortunately this isn't yet fixed due to an access key conflict that went unnoticed. Patch incoming.
Assignee: nobody → past
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8813600 [details]
Fix the access key conflict in the password manager prompt (bug 1279586).

https://reviewboard.mozilla.org/r/95038/#review95246

Looks good and works for me, thanks!
Attachment #8813600 - Flags: review?(jhofmann) → review+
Pushed by pastithas@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/966bed7e5627
Fix the access key conflict in the password manager prompt . r=johannh
https://hg.mozilla.org/mozilla-central/rev/966bed7e5627
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
For future reference, you don't need to change the string ID if you're fixing a conflict in English. Each locales has its own accesskeys, and should already have them sorted out.

On the other hand, it would be great to use consistent naming to help tools.

Bad:
togglePasswordLabel=Show password
togglePasswordAccessKey2=h

Good:
togglePassword.label=Show password
togglePassword.accessKey=h
QA Whiteboard: [good first verify]
I have reproduced this bug with Nightly 50.0a1 (2016-06-10) on Windows 8 , 64 Bit!

This bug's fix is verified with latest Beta!

Build   ID 20170320143328
User Agent Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
[bugday-20170322]
You need to log in before you can comment on or make changes to this bug.