Closed Bug 1279664 Opened 5 years ago Closed 5 years ago

GLX context creation result is not checked in GLXVsyncSource::GLXDisplay::SetupGLContext

Categories

(Core :: Graphics, defect)

50 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed

People

(Reporter: acomminos, Assigned: acomminos)

References

Details

Was digging through crashstats when I found a few crashes like these;

https://crash-stats.mozilla.com/report/index/a179b62c-6034-4af2-a317-571d02160610

Should be easily fixed by checking if the result of GLContextGLX::CreateGLContext is null.
Pushed by acomminos@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4dec14c70fc9
Handle GL context creation failing in the GLX vsync provider. r=me
https://hg.mozilla.org/mozilla-central/rev/4dec14c70fc9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Duplicate of this bug: 1280262
You need to log in before you can comment on or make changes to this bug.