Highlighted word has an extra space after stylized characters

VERIFIED FIXED

Status

()

Toolkit
Find Toolbar
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Fanolian, Unassigned)

Tracking

(Blocks: 1 bug, {nightly-community, regression, testcase})

50 Branch
nightly-community, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8762295 [details]
findbar_stylized.html

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160611030214

Steps to reproduce:

1. Open attached testcase.
2. Search for "testcase" (without quote).


Actual results:

An extra space between T and C for the highlighted item.
There is no extra spaces if I manually add a space after stylized characters. (4th line, search for "test case")

p.s. Some highlighted words are stylized but stylized too much. See <b> or <code>.
(Reporter)

Updated

2 years ago
Blocks: 384458

Updated

2 years ago
Keywords: nightly-community
confirmed
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
[Tracking Requested - why for this release]: Regression
status-firefox49: --- → unaffected
status-firefox50: --- → affected
tracking-firefox50: --- → ?
Keywords: regression
Feature has been backed out so not tracking these bugs for 50.
tracking-firefox50: ? → ---
Blocks: 1291278
Bulk update to find bar bugs that won't be in 50 (according to https://bugzilla.mozilla.org/show_bug.cgi?id=1279695#c4 and local testing).
status-firefox50: affected → unaffected
Seems this is due to us drawing multiple boxes for the currently-found work, and those boxes pick up the default padding. When using multiple boxes we probably want to set left/right padding to 0.
Duplicate of this bug: 1302029
This will be fixed by bug 1305033.
Depends on: 1305033
Flags: qe-verify+
Flags: firefox-backlog+

Comment 8

2 years ago
Bug 1305033 is verified fixed. Should this bug be tested and closed?
I checked the attached (visual) test case and I agree it looks fixed.
Fanolian, please feel free to re-open if you feel otherwise!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
status-firefox51: --- → unaffected
status-firefox52: --- → fixed
I have reproduced this issue using Firefox 50.0a1 (2016.06.11) on Win 8.1 x64.
I can confirm this issue is fixed, I verified using Firefox 52.0b2 on Win 8.1 x64, Ubuntu 16.04 x64 and Mac OS X 10.11.
Status: RESOLVED → VERIFIED
status-firefox52: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.