Closed Bug 1279748 Opened 6 years ago Closed 6 years ago

Strange Codemirror behaviour at caret

Categories

(Core :: Layout, defect)

48 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1276467
Tracking Status
firefox49 --- fixed
firefox50 --- fixed

People

(Reporter: mconley, Unassigned)

References

Details

(Keywords: regression)

I'm able to reproduce this in Review Board (which uses Codemirror for its textarea inputs) and its bug tracker Splat (which uses the same), but the following is pretty straight forward to demonstrate:

STR:

1) Visit http://codemirror.net/
2) In the "This is Codemirror" example editor, double click to select an item
3) Keep clicking around. Eventually, the caret will look like this:

http://www.screencast.com/t/xVCBrdcQw0

ER:

A normal caret

AR:

A weird double-caret thing: http://www.screencast.com/t/xVCBrdcQw0

I used mozregression and I think I've narrowed this down to bug 1275411.

The weirdness is less bad here on Codemirror. It looks much worse on Splat:

http://puu.sh/pex0A/34ab50d5b8.png
This sounds like a dupe of bug 1276467, except you got a different regression range.
Mike shall we close this as a DUPE? (see above comment)
Flags: needinfo?(mconley)
Yeah, good call.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mconley)
Resolution: --- → DUPLICATE
Duplicate of bug: 1276467
Version: unspecified → 48 Branch
You need to log in before you can comment on or make changes to this bug.