Make mach build faster work for Thunderbird

RESOLVED WONTFIX

Status

()

Core
Build Config
RESOLVED WONTFIX
2 years ago
3 months ago

People

(Reporter: Fallen, Assigned: Fallen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
I'd appreciate if we could include a quick hack for making mach build faster work with Thunderbird.

The problem is that the repackage target is called in the wrong directory since MOZ_BUILD_APP is ../mail. A quick workaround would be to use $(notdir $(MOZ_BUILD_APP)) which would do nothing to "browser", but clean up "../mail" to "mail".

From reading the TODO comment, the code is slated to go away anyway, so this won't be permanent.
(Assignee)

Comment 1

2 years ago
Created attachment 8762373 [details] [diff] [review]
Fix - v1
Attachment #8762373 - Flags: review?(gps)

Comment 2

2 years ago
Comment on attachment 8762373 [details] [diff] [review]
Fix - v1

Review of attachment 8762373 [details] [diff] [review]:
-----------------------------------------------------------------

This seems acceptable.
Attachment #8762373 - Flags: review?(gps) → review+

Comment 3

2 years ago
Comment on attachment 8762373 [details] [diff] [review]
Fix - v1

Review of attachment 8762373 [details] [diff] [review]:
-----------------------------------------------------------------

Actually, no. Since "mobile/android" won't be pleased.
Attachment #8762373 - Flags: review+ → review-
(Assignee)

Comment 4

3 months ago
I'm going to prefer fixing this using bug 1366607 where it will work out of the box (mostly)
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.