Change Firefox_OS locale zones to B2G_OS

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: cmills, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:bug])

What did you do?
================
1. Went to https://developer.mozilla.org/it/docs/Mozilla/Firefox_OS
2. Moved it and all its children to https://developer.mozilla.org/it/docs/Mozilla/B2G_OS


What happened?
==============
Because of zone buginess, all the italian B2G_OS pages now fail with the error

"The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

What should have happened?
==========================
The pages correctly load.

Is there anything else we should know?
======================================
Here's what John told Chris about this, to make sure it's not lost:

I think it would be a small change, but I haven't looked too deeply into it.  My guess is URL root for the the zone record is incorrect:

Italian - https://developer.mozilla.org/admin/wiki/documentzone/121/
English - https://developer.mozilla.org/admin/wiki/documentzone/21/

Fixing this, and all the B2G zones, would be a matter of adjusting the zone records, and a page move of the root document in the locales:

https://developer.mozilla.org/admin/wiki/documentzone/?all=
https://developer.mozilla.org/admin/wiki/document/?q=Mozilla+%2FFirefox_OS&locale__exact=it
Chris, we discussed this bug in the dev meeting yesterday and it turns out anyone with admin level access can do this from the django admin, there is no development work involved. If you want to give this a try, please go ahead. If this process is not successful, there might be another root cause for this that will require dev work.
(In reply to Kadir Topal [:atopal] from comment #2)
> Chris, we discussed this bug in the dev meeting yesterday and it turns out
> anyone with admin level access can do this from the django admin, there is
> no development work involved. If you want to give this a try, please go
> ahead. If this process is not successful, there might be another root cause
> for this that will require dev work.

Sounds good; I have no idea to do this however, so I'll need some pointers ;-)
OK, I fixed it:

1) Loaded English in one tab - https://developer.mozilla.org/admin/wiki/documentzone/21/
2) Loaded Italian in the second tab - https://developer.mozilla.org/admin/wiki/documentzone/121/
3) Copied CSS from the English to the Italian
4) Cleared the URL root on the Italian page so it matched the clear URL root on the English page
5) Saved

It works now: https://developer.mozilla.org/en-US/docs/Mozilla/B2G_OS

A similar technique should be used on all other B2G_OS zones. Here's the ones I can find:

Working:

en-US - https://developer.mozilla.org/admin/wiki/documentzone/21/
it    - https://developer.mozilla.org/admin/wiki/documentzone/121/

Still Firefox OS:

bn-BD - https://developer.mozilla.org/admin/wiki/documentzone/89/
de    - https://developer.mozilla.org/admin/wiki/documentzone/135/
es    - https://developer.mozilla.org/admin/wiki/documentzone/111/
fa    - https://developer.mozilla.org/admin/wiki/documentzone/77/
fr    - https://developer.mozilla.org/admin/wiki/documentzone/103/
pt-BR - https://developer.mozilla.org/admin/wiki/documentzone/81/
ro    - https://developer.mozilla.org/admin/wiki/documentzone/225/
ru    - https://developer.mozilla.org/admin/wiki/documentzone/221/
zh-CN - https://developer.mozilla.org/admin/wiki/documentzone/137/
zh-TW - https://developer.mozilla.org/admin/wiki/documentzone/97/

Changed to B2G_OS, but zone is still redirecting to Firefox_OS:

ja    - https://developer.mozilla.org/admin/wiki/documentzone/93/
Summary: Italian B2G_OS pages broken → Change Firefox_OS locale zones to B2G_OS
Thanks John, this technique worked well, and I've managed to fix most of the B2G_OS locales now, with a combination of editing the zone admin pages, and page moves.

There are a few left that have issues still.

1.

https://developer.mozilla.org/fr/docs/Mozilla/Firefox_OS
https://developer.mozilla.org/pt-BR/docs/Mozilla/Firefox_OS

When trying to move these pages, the result email comes up as failed, and the message given on the email is 

The exception raised was:

Exception type: <type 'exceptions.Exception'>

Exception message: Requested move would overwrite a non-redirect page.

Full traceback:

Traceback (most recent call last):
 File "/data/www/developer.mozilla.org/kuma/kuma/wiki/models.py", line 1139, in _move_tree
   child._move_tree('/'.join([new_slug, child_title]), user)
 File "/data/www/developer.mozilla.org/kuma/kuma/wiki/models.py", line 1085, in _move_tree
   self._move_conflicts(new_slug)
 File "/data/www/developer.mozilla.org/kuma/kuma/wiki/models.py", line 1050, in _move_conflicts
   raise Exception("Requested move would overwrite a non-redirect page.")
Exception: Requested move would overwrite a non-redirect page.

2.

https://developer.mozilla.org/vi/docs/Mozilla/Firefox_OS

This one gives me the error "Your requested move cannot be completed due to the following slug conflicts: Please try a different destination slug. Double check to be sure you're trying to move to the right place!"

So it looks like this exists already:

https://developer.mozilla.org/vi/docs/Mozilla/B2G_OS

For now I've put a redirect in place from the former to the latter so that the right page shows up correctly when you click the link in the translations list.

3.

https://developer.mozilla.org/ko/docs/Mozilla/Firefox_OS

This one gives me basically the same error message as the previous locale listed in 2. , but this time https://developer.mozilla.org/ko/docs/Mozilla/B2G_OS redirects to https://developer.mozilla.org/ko/docs/Mozilla/Firefox_OS, and https://developer.mozilla.org/ko/docs/Mozilla/B2G_OS$edit gives a page not found error.

So I'm not sure what to do here.
As a side note, all of the pages now work; the ones listed above are just at the wrong locations (wrong slugs).
Chris,

Thanks, much better.

The page moves resulted in some New Relic alerts last night.  There's a bug around page refreshes, and a topic move like this triggers it, and gets above the 5% of transactions limit for alerts.  I added an incident report at https://goo.gl/fMKU9X.

The English page's "Languages" dropdown had links to the Firefox OS pages, so there was a redirect when clicked. It was fixed with a force-refresh of the English page, to reset the page metadata.

Many pages are "good" - at the correct URL, and with the zone styling. The page title may still be "Firefox OS", but that can and should be handled by the translators:

https://developer.mozilla.org/en-US/docs/Mozilla/B2G_OS
https://developer.mozilla.org/ar/docs/Mozilla/B2G_OS
https://developer.mozilla.org/bn-BD/docs/Mozilla/B2G_OS
https://developer.mozilla.org/de/docs/Mozilla/B2G_OS
https://developer.mozilla.org/es/docs/Mozilla/B2G_OS
https://developer.mozilla.org/fa/docs/Mozilla/B2G_OS
https://developer.mozilla.org/it/docs/Mozilla/B2G_OS
https://developer.mozilla.org/ja/docs/Mozilla/B2G_OS
https://developer.mozilla.org/pt-PT/docs/Mozilla/B2G_OS
https://developer.mozilla.org/ro/docs/Mozilla/B2G_OS
https://developer.mozilla.org/ru/docs/Mozilla/B2G_OS
https://developer.mozilla.org/th/docs/Mozilla/B2G_OS
https://developer.mozilla.org/tn/docs/Mozilla/B2G_OS
https://developer.mozilla.org/zh-CN/docs/Mozilla/B2G_OS
https://developer.mozilla.org/zh-TW/docs/Mozilla/B2G_OS

There are several pages at the right URL, but without zone styling. It is possible that this is OK, and we should remove the zone styling (and the zone records) for all the B2G OS pages:

https://developer.mozilla.org/ca/docs/Mozilla/B2G_OS
https://developer.mozilla.org/cs/docs/Mozilla/B2G_OS
https://developer.mozilla.org/el/docs/Mozilla/B2G_OS
https://developer.mozilla.org/he/docs/Mozilla/B2G_OS
https://developer.mozilla.org/hi-IN/docs/Mozilla/B2G_OS
https://developer.mozilla.org/hr/docs/Mozilla/B2G_OS
https://developer.mozilla.org/hu/docs/Mozilla/B2G_OS
https://developer.mozilla.org/id/docs/Mozilla/B2G_OS
https://developer.mozilla.org/ms/docs/Mozilla/B2G_OS
https://developer.mozilla.org/my/docs/Mozilla/B2G_OS
https://developer.mozilla.org/nl/docs/Mozilla/B2G_OS
https://developer.mozilla.org/pl/docs/Mozilla/B2G_OS
https://developer.mozilla.org/ta/docs/Mozilla/B2G_OS
https://developer.mozilla.org/tr/docs/Mozilla/B2G_OS
https://developer.mozilla.org/vi/docs/Mozilla/B2G_OS

I've started an MDN admin discussion on this possibility.

Finally, I have the problem pages:

https://developer.mozilla.org/fr/docs/Mozilla/Firefox_OS - Wrong URL
https://developer.mozilla.org/ko/docs/Mozilla/Firefox_OS - Translated, wrong URL, maybe styled?
https://developer.mozilla.org/pt-BR/docs/Mozilla/Firefox_OS - Translated, wrong URL, styled

I'll tackle those next, to see if there is anything I can do.
OK, fr fixed.

The process was:

1. Use the Django shell to find documents already in B2G namespace.  In this case it was:

/fr/docs/Mozilla/B2G_OS/Board_guide/CHIRIMEN
/fr/docs/Mozilla/B2G_OS/Board_guide/CHIRIMEN/OS_Image
/fr/docs/Mozilla/B2G_OS/Board_guide/CHIRIMEN/Quick_start_guide
/fr/docs/Mozilla/B2G_OS/Board_guide/CHIRIMEN/Quick_start_guide/board_connectors

2. Move these back to Firefox OS, by moving /fr/docs/Mozilla/B2G_OS/Board_guide/CHIRIMEN to /fr/docs/Mozilla/Firefox_OS/Board_guide/CHIRIMEN

3. Move /fr/docs/Mozilla/Firefox_OS to /fr/docs/Mozilla/B2G_OS

I omitted the step where I accidentally moved /en-US/docs/Mozilla/B2G_OS/Board_guide/CHIRIMEN.

On to ko, pr-BR, and vi (which I left out of last comment)
I fixed ko in a similar way to fr. In this case, the already-translated page was the Camera API:

https://developer.mozilla.org/ko/docs/B2G_OS/API/Camera_API

The ko API page should probably be reverted to the English version:

https://developer.mozilla.org/ko/docs/B2G_OS/API

For vi, the 6 pages under /Firefox_OS are redirects to the /B2G_OS equivalents. Good work Chris.

That leaves pr-BR, which caused the same issue you got.  Specifically, it says it can't move this document:

https://developer.mozilla.org/pt-BR/docs/Mozilla/Firefox_OS/Desenvolvendo_no_Firefox_OS/Personalizando_teclado_aplicativos_FirefoxOS

However, there are no documents under pt-BR in B2G_OS, so my previous trick does not work.  There is one bit of strangeness I noticed. This page:

https://developer.mozilla.org/pt-BR/docs/Mozilla/Firefox_OS/Desenvolvendo_no_Firefox_OS

is a translation of this page, moved to the Archive:

https://developer.mozilla.org/en-US/docs/Archive/Firefox_OS/Developing_Firefox_OS

so maybe there is something strange going on this that branch. However, there are other translations of that archived page that didn't cause trouble.

Digging in to see what I can find, and posting before Bugzilla loses my edit (again)
I was able to execute a partial move of the tree in the shell, then manually move the remaining dozen or so documents.  There was one strange document with a duplicate slug and barely any content - I deleted it.

I then looked for all remaining pages starting with "Mozilla/Firefox_OS", and handled them:

Moved to B2G_OS:
https://developer.mozilla.org/zh-CN/docs/Mozilla/Firefox_OS/Building
https://developer.mozilla.org/es/docs/Mozilla/Firefox_OS/Tips_and_tricks
https://developer.mozilla.org/cs/docs/Mozilla/Firefox_OS/Apps/Tipy_a_techniky
https://developer.mozilla.org/ms/docs/Mozilla/Firefox_OS/Firefox_OS_apps

Deleted:
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/UX/Building_blocks/List/Coding

Unchanged:
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/UX_overview
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/UX_overview/App_layout_guide
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/UX_overview/Icon_design
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/UX_overview/Building_blocks
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/UX_overview/Animation
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/User_interface_animation_design
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/How_to_connect_WebIDE_to_TV_(VIErA)
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/TV_broadcast_streams_Firefox_OS
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/Web_animations_on_large_screen
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/TV_remote_control_navigation
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/TV_remote_control_button_mapping_to_keyboard
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/Simulating_Firefox_OS_for_TV
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/Hello_world_example
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS_for_TV/Interacting_with_TV_remote_controls

I'm done with moving to B2G_OS. Chris, please close the bug if it looks OK to you now.
Flags: needinfo?(cmills)
Thanks a lot for your help on this John! Looks good to me.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(cmills)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.