-about:b2g-installer not reachable since v50.0a1

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: i.hoerler, Assigned: titannanomail, Mentored)

Tracking

({nightly-community})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

i clicked in the URL bar and wrote: "about:b2g-installer" and it didn't apear like in version 49.0a1.  


Actual results:

cold not find site is writen in the window below url bar.


Expected results:

it normaly opens the b2g-installer to flash a device. (the page with the rocket) :-)
(Reporter)

Updated

3 years ago
Component: Untriaged → Installer
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Version: 46 Branch → 50 Branch
Keywords: nightly-community
Component: Installer → B2gInstaller
Product: Firefox → Firefox OS
Version: 50 Branch → unspecified
Ok it's a trivial bug :)
Mentor: lissyx+mozillians
OS: Mac OS X → All
Since I would really like to onboard more people on the addon, I'd like that some contributors do fix this :)
Masahiko or Jovan, the problem lies within bootstrap.js around the dump() call in startup(). For some reason, this used to work but now the conversion to fails. Surrounding this with a try/catch does the job.

This is a good first bug, would you be willing to take it, send a PR and make sure tests are okay after? Thanks!
Flags: needinfo?(titannanomail)
Flags: needinfo?(chimantaea_mirabilis)
(Assignee)

Comment 5

3 years ago
how can I enable debug logging? dump() should show up in the browser console? Right now neither dump() or console.log() show up.
Flags: needinfo?(titannanomail) → needinfo?(lissyx+mozillians)
dump() should show, but check the js console not the webconsole. Start your firefox with "-jsconsole" :)
Flags: needinfo?(lissyx+mozillians)
(Assignee)

Comment 7

3 years ago
>  for (var p in data) {
>    dump("data." + p + '\n');
>    dump("data." + p + "=" + data[p] + "\n");
>  }

every property of data is dumped to the console, but data.instanceID can't be stringified for some reason... how should we handle this?
Flags: needinfo?(lissyx+mozillians)
(Assignee)

Comment 8

3 years ago
Created attachment 8762882 [details] [review]
TitanNano:Bug_1279947 > mozilla-b2g:master
Flags: needinfo?(lissyx+mozillians)
Attachment #8762882 - Flags: review?(lissyx+mozillians)
I'm not sure we really care
Assignee: nobody → titannanomail
Comment on attachment 8762882 [details] [review]
TitanNano:Bug_1279947 > mozilla-b2g:master

it's good but we could probably do more simply:
if (data[p] && data[p].toString) {
  dump("data." + p + "=" + data[p] + "\n");
} else {
  dump("data." + p + " cannot be dumped as a string\n");
}
Attachment #8762882 - Flags: review?(lissyx+mozillians) → review+
(Assignee)

Comment 11

3 years ago
How about this?

>     let value = null;
>    
>     if (data[p] && data[p].toString) {
>       value = "=" + data[p].toString();
>     } else {
>       value = " cannot be dumped as a string\n");
>     }
>
>     dump("data." + p + value + "\n");


We need the explicit call to .toString() because that makes it possible to get a string representation of the symbol "Symbol(b2g-installer@mozilla.org)" and not an exception.
 
I also don't quite understand why you want the dump(...) line twice.
Flags: needinfo?(lissyx+mozillians)
good for me this way :)
Flags: needinfo?(lissyx+mozillians)
(Assignee)

Comment 13

3 years ago
ok updated the PR, you can merge.
Flags: needinfo?(lissyx+mozillians)
https://github.com/mozilla-b2g/b2g-installer/commit/6c49e640dbd307b37b67498009632d58dd8acd5b
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(lissyx+mozillians)
Resolution: --- → FIXED
Thanks!
Flags: needinfo?(chimantaea_mirabilis)
Do you have a linux 64 and a mac 64 ? If so, would you mind doing a new release ? If not I'll do it but I don't have much time.
Flags: needinfo?(titannanomail)
(Assignee)

Comment 17

3 years ago
yes I have both, but I'd like to wait until we fix Bug 1275063, so we can re-submit to AMO.
Flags: needinfo?(titannanomail)
You need to log in before you can comment on or make changes to this bug.