Permission denied accessing document object from executeScript()

RESOLVED DUPLICATE of bug 1123506

Status

defect
RESOLVED DUPLICATE of bug 1123506
3 years ago
3 years ago

People

(Reporter: moz-bugzilla, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.84 Safari/537.36

Steps to reproduce:

1465840594040	Marionette	TRACE	conn0 -> [0,16,"executeScript",{"args":[],"newSandbox":false,"script":"return document.readyState","scriptTimeout":null,"specialPowers":false}]



Actual results:

1465840594043	Marionette	TRACE	conn0 <- [1,16,{"error":"javascript error","message":"Error: Permission denied to access property \"document\"","stacktrace":"execute_script\ninline javascript, line 0\nsrc: \"var __marionetteFunc = function(){return document.readyState};__marionetteFunc.apply(null, __marionetteParams);\"\nStack:\n__marionetteFunc@dummy file:0:35\n@dummy file:0:67\n"},null]



Expected results:

Return the readyState.

geckodriver 0.8.0 used with selenium 2.53.0

This works with all other drivers (Chrome, Remote+InterenetExplorer, PhantomJS, Firefox).
This unfortunately never got into the release branch. We have fixed this in bug 1123506 and we need to wait for it to hit release. You can have this work from Beta -> Nightly.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123506
It doesn't work with 48.0a1 which comes from firefox-nightly COPR repo.  I'll try again later.

It's a shame that FirefoxDriver is broken (forever?) and MarionetteDriver is broken (for a little while I hope) at the same time.
You need to log in before you can comment on or make changes to this bug.