Opening a link from Facebook Messenger chat head crashes Firefox (Android N)

RESOLVED FIXED in Firefox 51

Status

()

defect
P1
normal
Rank:
4
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rqou, Assigned: sebastian)

Tracking

(Blocks 1 bug)

48 Branch
Firefox 51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(platform-rel +, firefox50 affected, firefox51 fixed)

Details

(Whiteboard: [platform-rel-Facebook][MobileAS])

Attachments

(1 attachment)

Reporter

Description

3 years ago
User Agent: Mozilla/5.0 (Android N; Mobile; rv:48.0) Gecko/48.0 Firefox/48.0
Build ID: 20160607191837
Firefox for Android

Steps to reproduce:

1. (Possibly needed, uncertain) Be running Android N NPD35K
2. Have chat heads enabled in Facebook Messenger 
3. Have a friend send you a link via Facebook Messenger 
4. (Possibly needed, uncertain) Have Firefox be the app "under" the chat head when the chat head is expanded 
5. Tap on the received link


Actual results:

Animations play as if the page is about to open. Firefox then suddenly disappears and another app in the Android "app stack" replaces it. Reopening Firefox shows that all tabs are closed as if a crash occured. No crash dialog appears. Nothing is logged in about:crashes. 

This issue does not seem to happen if a link is tapped in Facebook Messenger launched "as a full app" rather than as a chat head.


Expected results:

The page should have loaded normally.
Whiteboard: [platform-rel-Facebook]
platform-rel: --- → ?
Blocks: android-n
platform-rel: ? → ---
Component: Untriaged → General
Product: Firefox → Firefox for Android
platform-rel: --- → ?
Kevin, does this repro for you? (I don't have access to an N device...)
Flags: needinfo?(kbrosnan)
I don't use Messenger. Maybe Sebastian?
Flags: needinfo?(kbrosnan) → needinfo?(s.kaspari)
I can reproduce this.

> 4. (Possibly needed, uncertain) Have Firefox be the app "under" the chat head when the chat head is expanded 

Yeah, this seems to be required. It happens when opening a link while the app is still technically in the foreground.
Flags: needinfo?(s.kaspari)
Assignee: nobody → s.kaspari
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2

Updated

3 years ago
Blocks: 1289140
platform-rel: ? → +

Comment 5

3 years ago
mozreview-review
Comment on attachment 8788508 [details]
Bug 1280112 - LauncherActivity: Remove task flags from incoming intent.

https://reviewboard.mozilla.org/r/76986/#review75216
Attachment #8788508 - Flags: review?(ahunt) → review+

Comment 6

3 years ago
Pushed by s.kaspari@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/25ae9569214c
LauncherActivity: Remove task flags from incoming intent. r=ahunt
Priority: P2 → P1
Whiteboard: [platform-rel-Facebook] → [platform-rel-Facebook][MobileAS]
Rank: 4

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/25ae9569214c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
This seems to have fixed more issues (bug 1204424) - We should consider uplifting this.
Flags: needinfo?(rqou)
Flags: needinfo?(rqou)
Iteration: --- → 1.4
You need to log in before you can comment on or make changes to this bug.