[webvtt] fix crash in TimeMarchesOn() when testing test_peerConnection_scaleResolution.html.

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED WORKSFORME
2 years ago
7 months ago

People

(Reporter: bechen, Assigned: bechen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
#01: nsTArray_base<nsTArrayInfallibleAllocator, nsTArray_CopyWithMemutils>::Length() const (/home/benjamin/hg/mozilla-central/objdir-linux/dist/include/nsTArray.h:361)
#02: mozilla::dom::HTMLMediaElement::FireTimeUpdate(bool) (/home/benjamin/hg/mozilla-central/dom/html/HTMLMediaElement.cpp:4831)
#03: mozilla::dom::HTMLMediaElement::StreamListener::DoNotifyOutput() (/home/benjamin/hg/mozilla-central/dom/html/HTMLMediaElement.cpp:3153)
#04: mozilla::dom::HTMLMediaElement::StreamListener::DoNotifyHaveCurrentData() (/home/benjamin/hg/mozilla-central/dom/html/HTMLMediaElement.cpp:3165)
#05: nsRunnableMethodImpl<void (mozilla::dom::HTMLMediaElement::StreamListener::*)(), true, false>::Run() (/home/benjamin/hg/mozilla-central/objdir-linux/dist/include/nsThreadUtils.h:752)
#06: mozilla::MediaStreamGraphImpl::RunInStableState(bool) (/home/benjamin/hg/mozilla-central/dom/media/MediaStreamGraph.cpp:1921)
#07: Run (/home/benjamin/hg/mozilla-central/dom/media/MediaStreamGraph.cpp:1737)
#08: mozilla::CycleCollectedJSRuntime::ProcessStableStateQueue() (/home/benjamin/hg/mozilla-central/xpcom/base/CycleCollectedJSRuntime.cpp:1302)
#09: XPCJSRuntime::AfterProcessTask(unsigned int) (/home/benjamin/hg/mozilla-central/js/xpconnect/src/XPCJSRuntime.cpp:3788)
#10: nsThread::ProcessNextEvent(bool, bool*) (/home/benjamin/hg/mozilla-central/xpcom/threads/nsThread.cpp:1047)
#11: NS_ProcessNextEvent(nsIThread*, bool) (/home/benjamin/hg/mozilla-central/xpcom/glue/nsThreadUtils.cpp:290)
#12: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) (/home/benjamin/hg/mozilla-central/ipc/glue/MessagePump.cpp:101)
#13: MessageLoop::RunInternal() (/home/benjamin/hg/mozilla-central/ipc/chromium/src/base/message_loop.cc:236)
#14: ~AutoRunState (/home/benjamin/hg/mozilla-central/ipc/chromium/src/base/message_loop.cc:493)
#15: nsBaseAppShell::Run() (/home/benjamin/hg/mozilla-central/widget/nsBaseAppShell.cpp:158)
#16: nsAppStartup::Run() (/home/benjamin/hg/mozilla-central/toolkit/components/startup/nsAppStartup.cpp:285)
#17: XREMain::XRE_mainRun() (/home/benjamin/hg/mozilla-central/toolkit/xre/nsAppRunner.cpp:4376)
#18: XREMain::XRE_main(int, char**, nsXREAppData const*) (/home/benjamin/hg/mozilla-central/toolkit/xre/nsAppRunner.cpp:4479)
#19: XRE_main (/home/benjamin/hg/mozilla-central/toolkit/xre/nsAppRunner.cpp:4587)
Could not determine endianness of /home/benjamin/hg/mozilla-central/objdir-linux/dist/bin/firefox
#20: ??? (/home/benjamin/hg/mozilla-central/objdir-linux/dist/bin/firefox)
#21: ??? (/home/benjamin/hg/mozilla-central/objdir-linux/dist/bin/firefox)
Could not determine endianness of /lib/x86_64-linux-gnu/libc.so.6
#22: __libc_start_main (/build/eglibc-oGUzwX/eglibc-2.19/csu/libc-start.c:321)
#23: ??? (/home/benjamin/hg/mozilla-central/objdir-linux/dist/bin/firefox)
#24: ??? (???:???)
ExceptionHandler::GenerateDump cloned child 12928
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
TEST-INFO | Main app process: exit 11
TEST-UNEXPECTED-FAIL | dom/media/tests/mochitest/test_peerConnection_scaleResolution.html | application terminated with exit code 11
(Assignee)

Comment 1

2 years ago
Created attachment 8762832 [details]
CurrentTime backward

The attachment prints the HTMLMediaElement::CurrentTime(). It shows that during the testing dom/media/tests/mochitest/test_peerConnection_scaleResolution.html, the playback position goes backward.
(Assignee)

Comment 2

2 years ago
I can reproduce it at "hg revision 1828937da949", see bug 887934. But can't reproduce it at the latest nightly.
(Assignee)

Updated

2 years ago
See Also: → bug 1280814
Priority: -- → P2
Mass change P2 -> P3
Priority: P2 → P3
(Assignee)

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.