Suggestion dropdown for the address bar is misplaced (Linux, Gtk3)

RESOLVED DUPLICATE of bug 1022241

Status

()

RESOLVED DUPLICATE of bug 1022241
3 years ago
3 years ago

People

(Reporter: kalherak, Unassigned)

Tracking

({regression})

46 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8762867 [details]
firefox-dropdown.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

- start Firefox (new installation, new user with empty $HOME, no addons)
- open several tabs
- repeat:
     - type something in the address bar (suggestion dropdown opens)
     - switch between tabs
     - maximize/un-maximize window


Firefox 47.0  Linux x86_64 (https://download.mozilla.org/?product=firefox-47.0-SSL&os=linux64&lang=en-US)
Linux Mint 17.3 Rosa


Actual results:

The dropdown with the suggestions is not opened below the address bar, but somewhere else on the screen (random),
sometimes it covers the address bar, so I can't see what I'm typing in.
(see the attachment)

(The same misplacement problem was observed in other input fields too, e.g. when entering saved user name + password)


Expected results:

The dropdown is opened below the input field.

Comment 1

3 years ago
Is it reproducible in previous versions of Firefox like 46 or 45?
http://ftp.mozilla.org/pub/firefox/releases/46.0.1/
http://ftp.mozilla.org/pub/firefox/releases/45.0.2/
Flags: needinfo?(kalherak)

Comment 2

3 years ago
I couldn't reproduce this on 

Version 	47.0
Build ID 	20160604131506
User Agent 	Mozilla/5.0 (X11; Linux i686; rv:47.0) Gecko/20100101 Firefox/47.0

Please provide info requested in comment 1. Thanks!

Comment 4

3 years ago
Created attachment 8766875 [details]
blurred.png

A more extreme example of the bug being discussed

Comment 5

3 years ago
(In reply to connorsinnott@gmail.com from comment #4)
> Created attachment 8766875 [details]
> blurred.png
> 
> A more extreme example of the bug being discussed

I found that I do not experience this bug until I focus on an input field, at which point this bug will remain until I recreate the tab. The suggestions for forum input are also misplaced once this bug begins.

Comment 6

3 years ago
Created attachment 8766888 [details]
bug.mp4

Mozilla Firefox 47.0

To reproduce:
- Open Firefox
- Type in address bar
- Move window
- Type in address bar again
- Open a new tab
- Now all suggestions for all tabs will be displayed in the same area as step 2

Comment 7

3 years ago
Are you working with 2 displays?
If yes, it could be a recent regression.

Can you install the tool mozregression (see http://mozilla.github.io/mozregression/ for details) and run the command "mozregression --good=44" then copy here the final pushlog to narrow down a regression range.

Comment 8

3 years ago
spectre@spectre-Z97X-UD5H ~ $ mozregression --good=44
**********
You should use a config file. Please use the --write-config command line flag to help you create one.
**********

 0:00.13 INFO: No 'bad' option specified, using 2016-07-02
 0:00.13 INFO: Using date 2015-10-29 for release 44
 0:01.18 INFO: Testing good and bad builds to ensure that they are really good and bad...
 0:01.18 INFO: Downloading build from: https://archive.mozilla.org/pub/firefox/nightly/2015/10/2015-10-29-04-52-27-mozilla-central/firefox-45.0a1.en-US.linux-x86_64.tar.bz2
===== Downloaded 100% =====
 0:05.29 INFO: Running mozilla-central build for 2015-10-29
 0:12.63 INFO: Launching /tmp/tmpwt14VT/firefox/firefox
 0:12.63 INFO: application_buildid: 20151029045227
 0:12.63 INFO: application_changeset: acb3f4ac5424181d3d4d73283668162137918cf1
 0:12.63 INFO: application_name: Firefox
 0:12.63 INFO: application_repository: https://hg.mozilla.org/mozilla-central
 0:12.63 INFO: application_version: 45.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry' or 'exit' and press Enter): bad
 0:25.40 ERROR: Build was expected to be good! The initial good/bad range seems incorrect.

So the first regression I tested had the same issue, should I go back further?

Comment 9

3 years ago
Here is the pushlog, I started at --good=38

10:19.62 INFO: Last good revision: 1ee54e043b9b05d69e6a9f981aa6c4ef0dd65be3
10:19.62 INFO: First bad revision: 939320b957c588ad809e9b4a64b7f232dd4d9b72
10:19.62 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1ee54e043b9b05d69e6a9f981aa6c4ef0dd65be3&tochange=939320b957c588ad809e9b4a64b7f232dd4d9b72

Comment 10

3 years ago
I do have two displays, however this bug still appears when I have only one monitor enabled.

Comment 11

3 years ago
It seems to be a Gtk3 bug, since FF46 (1st support of Gtk3).
Blocks: 627699
Component: Untriaged → Widget: Gtk
Flags: needinfo?(kalherak)
Keywords: regression
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
Summary: Suggestion dropdown for the address bar is misplaced → Suggestion dropdown for the address bar is misplaced (Linux, Gtk3)

Updated

3 years ago
Version: 47 Branch → 46 Branch
See Also: → bug 1283801
Thanks.  I think this is the same issue as bug 1022241.
http://distrowatch.com/table.php?distribution=mint says that Mint 17.3 has GTK+ 3.10.8.  I don't know whether this is limited to only some GTK versions, but it seems that some are seeing this bug while others are not.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022241
You need to log in before you can comment on or make changes to this bug.