If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Text / caret gets duplicated at jsfiddle.net

RESOLVED DUPLICATE of bug 1277251

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1277251
a year ago
a year ago

People

(Reporter: dholbert, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
STR:
 1. Visit https://jsfiddle.net/
 2. Click in the "HTML" fancy-canvasy-textbox thing (the upper left one)
 3. Type a few characters (e.g. "a", and then "b", and then "c")

ACTUAL RESULTS:
After you type a character, an extra "ghost" version of it shows up as well, offset a bit.  After you stop typing for a second or two, the ghost versions disappear.

EXPECTED RESULTS:
No ghost versions.

I'm pretty sure this is a somewhat recent regression.
I'm using Nightly 50.0a1 (2016-06-15) with a fresh profile.
(Reporter)

Comment 1

a year ago
(Also, the blinky caret line gets duplicated towards the upper left.)
(Reporter)

Comment 2

a year ago
Created attachment 8763131 [details]
screencast of bug

Here's a screencast of the bug, with latest Firefox nightly.
(Reporter)

Comment 3

a year ago
Range from mozregression:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cc9051869d1a9078a821da5d1639299f9e836e0e&tochange=1ee604ae873ffae665e745b3553fb1c406dbdd6a

--> caused by Bug 1265237

Which helped me discover bug 1277251, which this is a dupe of (and which itself is a dupe of a more generic bug).  (Though,  bug 1277251 is tagged as e10s-specific, whereas I can reproduce versions of this bug in e10s as well as non-e10s profiles. I'll add a note about that on the other bug.)
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox50: affected → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1277251
You need to log in before you can comment on or make changes to this bug.