Closed Bug 1280525 Opened 4 years ago Closed 3 years ago

Search highlight (Ctrl + F) does not work properly when text is erased

Categories

(Toolkit :: Find Toolbar, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox49 --- unaffected
firefox50 --- fixed

People

(Reporter: beberveiga, Assigned: jyeh)

References

Details

(Keywords: regression, Whiteboard: [nightly-community])

Attachments

(2 files)

Attached image error.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160616030228

Steps to reproduce:

1 - Press Ctrl + F.
2 - Type a word present in the current web page.
3 - Erase the whole search criteria.


Actual results:

The search criteria (or part of it) continues highlighted. The gray overlay continues on the page.


Expected results:

The highlight and the overlay must not continue on the page.
Whiteboard: [nightly-community]
Blocks: 384458
Component: Untriaged → Find Toolbar
Product: Firefox → Toolkit
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hi Mike,

I just made a simple patch for this bug. Any feedback is welcome :)

Thanks!
Assignee: nobody → jyeh
Attachment #8767862 - Flags: review?(mdeboer)
Looks like duplicate with Bug 1280061, is it?
Comment on attachment 8767862 [details] [diff] [review]
0001-Bug-1280525-Search-highlight-Ctrl-F-does-not-work-pr.patch

Review of attachment 8767862 [details] [diff] [review]:
-----------------------------------------------------------------

Good find :)
Attachment #8767862 - Flags: review?(mdeboer) → review+
Duplicate of this bug: 1280061
Feature has been backed out so not tracking these bugs for 50.
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/eb47026cced7
Search highlight (Ctrl + F) does not work properly when text is erased. r=mdeboer
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/eb47026cced7
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.