SVG xlink image (external) fails to render, when SVG is used as an image

RESOLVED DUPLICATE of bug 739726

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 739726
2 years ago
2 years ago

People

(Reporter: Geoffrey Roberts, Unassigned)

Tracking

47 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
If an SVG image is embedded via one of the following methods, any xlinked images within the SVG fail to render.

* <img> tag
* CSS background
* CSS content attribute

Inline SVG does not exhibit this problem.

Test cases:

* https://rtrvrtg.github.io/svg-embed-xlink-tests/index.html (xlinked raster image)
* https://rtrvrtg.github.io/svg-embed-xlink-tests/index-vector.html (xlinked vector image)

Test results across browsers:

* https://rtrvrtg.github.io/svg-embed-xlink-tests/test-results.md
Thanks for the bug report! This is actually exactly the intended behavior.  This is a duplicate of (invalid) bug 739726 -- see discussion there for more.  (And if you like, see bug 628747 where we made this change.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Summary: SVG xlink image fails to render → SVG xlink image (external) fails to render, when SVG is used as an image
Duplicate of bug: 739726
You need to log in before you can comment on or make changes to this bug.