Dotted square does not follow the smooth zoom animation of icons from toolbar

VERIFIED FIXED in Firefox 50

Status

()

Firefox
Theme
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: bogdan_maris, Assigned: jaws)

Tracking

Trunk
Firefox 50
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 affected, firefox49 affected, firefox50 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

a year ago
Created attachment 8763222 [details]
Screencast showing the issue

[Affected versions]:
- Firefox 48 beta 1
- latest Developer Edition 49.0a2
- latest Nightly 50.0a1

[Affected platforms]:
- Windows 8.1 64-bit
- Windows 10 64-bit

[Unaffected platforms]:
- Mac OS X 10.10.5
- Ubuntu 16.04 64-bit

[Steps to reproduce]:
1. Start Firefox
2. Enter Customization
3. Press Tab key
4. Click one icon from toolbar (more visible using searchbar)

[Expected result]:
- Dotted square follows the smooth zoom transition of clicked icons

[Actual result]:
- Dotted square remains behind the zoom transition of clicked icons

[Regression range]:
- This is not a regression, it reproduces since accessibility support was added in bug 1116578

[Additional notes]:
- Gif attached showing the issue on windows. Here is a comparison with Ubuntu 16.04 64, where the transition is smooth (https://db.tt/E4BfJOwM)
(Reporter)

Updated

a year ago
OS: All → Windows
FWIW, I see the broken behaviour on Linux as well. Not sure what's responsible for the difference with your screencast. I'm not sure why the outline isn't transitioned the same way as the size of the item itself. :-\
Component: Toolbars and Customization → Theme
(Reporter)

Comment 2

a year ago
(In reply to :Gijs Kruitbosch from comment #1)
> FWIW, I see the broken behaviour on Linux as well. Not sure what's
> responsible for the difference with your screencast. I'm not sure why the
> outline isn't transitioned the same way as the size of the item itself. :-\

I can confirm this as well on Ubuntu 14.04 64. My initial testing was performed on 16.04 32, and I can't reproduce there.
OS: Windows → All
Summary: [windows] Dotted square does not follow the smooth zoom animation of icons from toolbar → Dotted square does not follow the smooth zoom animation of icons from toolbar
Created attachment 8764664 [details]
Bug 1280618 - Dotted square does not follow the smooth zoom animation of icons from toolbar.

Review commit: https://reviewboard.mozilla.org/r/60392/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/60392/
Attachment #8764664 - Flags: review?(gijskruitbosch+bugs)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Comment on attachment 8764664 [details]
Bug 1280618 - Dotted square does not follow the smooth zoom animation of icons from toolbar.

https://reviewboard.mozilla.org/r/60392/#review57296

r=me on the assumption that you tested this and it works well. See below for a minor nit.

::: browser/themes/shared/customizableui/customizeMode.inc.css:274
(Diff revision 1)
> +
> +toolbarpaletteitem[place="palette"]:not([mousedown="true"]):-moz-focusring,
> +toolbarpaletteitem[place="panel"]:not([mousedown="true"]):-moz-focusring,
> +toolbarpaletteitem[place="toolbar"]:not([mousedown="true"]):-moz-focusring {
> +  /* Delay adding the focusring back until after the transform transition completes. */
> +  transition: outline-width .01s linear .3s;

Can we use a variable for the transition duration of the transform and the delay here? (It's possible the answer is 'no', I'm fuzzy on some of the interactions/usecases of calc and/or variables and units and gecko)
Attachment #8764664 - Flags: review?(gijskruitbosch+bugs) → review+
Created attachment 8764702 [details] [diff] [review]
Patch for check-in
Attachment #8764664 - Attachment is obsolete: true
Keywords: checkin-needed

Comment 6

a year ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/f8b271590318
Dotted square does not follow the smooth zoom animation of icons from toolbar. r=gijs
Keywords: checkin-needed

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f8b271590318
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox50: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50

Comment 8

a year ago
I have reproduced this bug with Firefox nightly 50.0a1 (2016-06-17)on Windows 10, 64 Bit.

The Bug's fix is now verified on latest nightly 50.0a1!
Build ID:  	20160713030216
User Agent: 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

[bugday-20160713]
I have reproduced this bug on Nightly 50.0a1 (2016-06-17) (Build ID: 20160617030217) on Linux, 64 bit!

The bug's fix is now verified on Latest Nightly 50.0a1!

Build ID: 20160713030216
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
OS: Ubuntu 16.04, Linux 4.4.0-28-generic

As this bug's fix is also verified on Windows 10, 64 bit (comment 8), I am marking this as verified!
Status: RESOLVED → VERIFIED
QA Whiteboard: [bugday-20160713]
status-firefox50: fixed → verified
You need to log in before you can comment on or make changes to this bug.