bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

video playback sometimes causes a crash with signature atidxx64.dll@0x1e2a4

RESOLVED DUPLICATE of bug 1275524

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1275524
2 years ago
2 years ago

People

(Reporter: Martin Schwaighofer, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], crash signature)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

Watching videos on youtube. It seems to happen more often when I'm switching tabs a lot and actively browse around while watching a video, but I can't find a scheme to reproduce it.


Actual results:

Firefox hangs, both my screens go black for 2 seconds because the graphics driver crashes, Windows restarts my graphics driver, so my screen comes back to life and I see that Firefox has crashed.




Expected results:

I would have expected video playback to continue normally.
(Reporter)

Comment 1

2 years ago
I think the underlying issue may also cause another phenomenon that I encounter quite often, where during video playback a fraction of the video frames or all the video frames are replaced by an image of the whole page. So the box which should contain the video suddenly contains an image of the surrounding page it's on. If I scroll the page, the page in the faulty video box scrolls as well.

This phenomenon occurs under the same circumstances and is resolved by a page reload.
(Reporter)

Updated

2 years ago
Summary: video playback sometimes causes a crash with signature atidxx64.dll@0x838bb → video playback sometimes causes a crash with signature atidxx64.dll@0x1e2a4
(Reporter)

Updated

2 years ago
Crash Signature: atidxx64.dll@0x1e2a4
I can not reproduce this issue on Mozilla/5.0 (Windows NT 6.3; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Please download the newest nightly version at: https://nightly.mozilla.org/
and clean(refresh) your profile at: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings
Flags: needinfo?(meschti)
(Reporter)

Comment 3

2 years ago
I installed the newest version of Nightly and created a new profile, which I used to browse a bit.
A specific ad starting on youtube then triggered all my tabs going black except for html5 video playback, which resumed normally. I'm adding screenshots of the youtube tab with the ad which caused the issue to occur and of a facebook tab which was also affected, like all other tabs.

I do think however that the problem is specific to my GPU driver version or GPU, and I think in similar cases GPU support was disabled for affected system configurations by some flag.

As I said I don't have issues with other GPU accelerated applications besides Firefox.
(Reporter)

Comment 4

2 years ago
Created attachment 8764874 [details]
An image of my youtube tab after the picured ad started playing and made the rest of the page render totally black.
(Reporter)

Comment 5

2 years ago
Created attachment 8764875 [details]
An image of another tab (facebook) to show that this is not an issue on youtube's end
(Reporter)

Comment 6

2 years ago
Just to be clear, the symptoms were different on Firefox 47, but to me it looks like the same underlying issue of 'parts of the page rendering totally black after some random point in time'. I will use Nightly for a bit and if this also causes a real crash for me in Nightly I will report back with that info.
Component: Untriaged → Graphics
Flags: needinfo?(meschti)
Product: Firefox → Core
Martin, could you give us the about:support graphics section?  This sounds like an ATI driver bug, that has been fixed recently.  I would expect the problem to go away if you update to the newest driver, or turn acceleration off in Firefox (about:preferences#advanced).  New driver is preferable, as otherwise things slow down.

The reason you don't see with other applications - Firefox is very aggressive in how it tries to accelerate videos, and it seems we're fairly unique, so the driver vendors never quite tested for that scenario.

The driver bug causes a driver crash/reset.  That sometimes takes Firefox down with it, sometimes "just" leaves you with the types of artifacts you describe.
Whiteboard: [gfx-noted]
(Reporter)

Comment 8

2 years ago
Thank you very much. I have an R9 270X. There is the about:support graphics section after turning hardware acceleration back on, which I had already turned off to mitigate the problem: 

Graphics
Adapter Description	AMD Radeon R9 200 Series
Adapter Drivers	aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	2048
Asynchronous Pan/Zoom	none
Device ID	0x6810
Direct2D Enabled	true
DirectWrite Enabled	true (10.0.10586.494)
Driver Date	5-15-2016
Driver Version	16.200.1010.1002
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	00000000
Supports Hardware H264 Decoding	Yes
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon R9 200 Series Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasAccelerated	0
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo

I've updated to the most recent driver as of now now, and this is the updated  about:support graphics section:

Adapter Description	AMD Radeon R9 200 Series
Adapter Drivers	aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	2048
Asynchronous Pan/Zoom	none
Device ID	0x6810
Direct2D Enabled	true
DirectWrite Enabled	true (10.0.10586.494)
Driver Date	7-8-2016
Driver Version	16.200.1035.1001
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	00000000
Supports Hardware H264 Decoding	Yes
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon R9 200 Series Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasAccelerated	0
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo

I will report back if the issue is fixed with the updated driver or not.
Yes, please, let us know.  If this problem goes away, then this sounds a lot like bug 1275524.
See Also: → bug 1275524
(Reporter)

Comment 10

2 years ago
The issue is resolved now. I agree that it sounds a like it's bug 1275524. Thank you very much for pointing that out, I had searched but I didn't find that this was already reported previously.

Comment 11

2 years ago
Looks that this bug is still active. Any reason it's still around?
Flags: needinfo?(milan)
Making it a duplicate of bug 1275524 given comment 10.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(milan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1275524
You need to log in before you can comment on or make changes to this bug.