remove Gecko_HashAtom in favor of stylo poking at mHash directly

RESOLVED FIXED in Firefox 50

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: heycam, Assigned: heycam)

Tracking

(Blocks: 1 bug)

unspecified
mozilla50
Points:
---

Firefox Tracking Flags

(firefox50 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Gecko_HashAtom is no longer needed given https://github.com/servo/servo/pull/11784 which makes stylo poke directly at nsIAtom::mHash.
(Assignee)

Comment 1

2 years ago
Created attachment 8763341 [details] [diff] [review]
patch
Attachment #8763341 - Flags: review?(dholbert)
Attachment #8763341 - Flags: review?(dholbert) → review+

Updated

2 years ago
Duplicate of this bug: 1280745

Comment 3

2 years ago
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2a2a78a056ed
Remove Gecko_HashAtom in favor of stylo poking at mHash directly. r=dholbert

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2a2a78a056ed
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.