Closed Bug 1280773 Opened 3 years ago Closed 2 years ago

turn tracking protection into a complete flexible content blocking feature

Categories

(Firefox :: Tracking Protection, enhancement)

50 Branch
enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: karana, Unassigned)

Details

(Whiteboard: tp-product)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160618024505




Expected results:

Firefox has a new feature to prevent tracking from websites.
Currently it only filters elements based on a curated list from disconnect.me
Depending on a single source is bad, the user can't influence and edit the list.

I would prefer if users could add their own subscription lists to firefox like you can already add your own lists in external addons like Ublock Origin or ABP for Firefox/Chrome or Blockr on IOS.

I also would like to see this feature being able to do the following additional things:

-  group urls into categories and name that group according to the related ad or tracking network as Ghostery already does it
- filter javascript , especially inline if it matches a certain regex
- offer replacement scripts to keep the website working and still prevent unwanted tracking
- allow certain objects (comments , video players, sound player, surveys..) to become click-to-play (Ghostery has an example for that)
Component: Untriaged → Tracking Protection
Severity: normal → enhancement
Whiteboard: tp-product
This includes a number of different features, so I will respond to each separately.

(In reply to Selek Respa from comment #0)
> -  group urls into categories and name that group according to the related
> ad or tracking network as Ghostery already does it

We are revamping the doorhanger in bug 1388915 to include some of this information and to make it closer to products like Ghostery.

> - filter javascript , especially inline if it matches a certain regex

The way that Tracking Protection is implemented doesn't allow us to do this and we'd have to have a good reason to change this because it would be a significant amount of work. WONTFIX for now.

> - offer replacement scripts to keep the website working and still prevent
> unwanted tracking

While we aren't going to shim every script we block, it's possible we'll do this in order to make some important websites work.

> - allow certain objects (comments , video players, sound player, surveys..)
> to become click-to-play (Ghostery has an example for that)

That's something that would be done outside of Tracking Protection and so separate bugs should be filed for this. The good news is that Flash is now mostly click-to-play (see bug 1365714).
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.