DOM events not fired on interacting with <input type=file> element

RESOLVED FIXED in Firefox 50

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ato, Assigned: ato)

Tracking

(Blocks 1 bug)

Version 3
mozilla51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 wontfix, firefox50 fixed, firefox51 fixed)

Details

Attachments

(5 attachments, 1 obsolete attachment)

Assignee

Description

3 years ago
Events such as onchange are not being fired when “interacting”, or calling the Element Send Keys command, on <input type=file> elements.

This is probably because we have to use privileged chrome APIs to set the file on this element because we can’t use the interaction library.
Assignee

Updated

3 years ago
Blocks: webdriver
Assignee

Updated

3 years ago
Duplicate of this bug: 1286107
Assignee

Updated

3 years ago
Assignee: nobody → ato
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee

Updated

3 years ago
Blocks: 1244425

Comment 8

3 years ago
mozreview-review
Comment on attachment 8784866 [details]
Bug 1280947 - Improve names of JSON marshaling methods in Marionette client;

https://reviewboard.mozilla.org/r/74170/#review72136
Attachment #8784866 - Flags: review?(dburns) → review+

Comment 9

3 years ago
mozreview-review
Comment on attachment 8784867 [details]
Bug 1280947 - Support tuples for script arguments;

https://reviewboard.mozilla.org/r/74172/#review72142

Comment 10

3 years ago
mozreview-review
Comment on attachment 8784867 [details]
Bug 1280947 - Support tuples for script arguments;

https://reviewboard.mozilla.org/r/74172/#review72144
Attachment #8784867 - Flags: review?(dburns) → review+

Comment 11

3 years ago
mozreview-review
Comment on attachment 8784868 [details]
Bug 1280947 - Remove dead File object construction code;

https://reviewboard.mozilla.org/r/74174/#review72146
Attachment #8784868 - Flags: review?(dburns) → review+

Comment 12

3 years ago
mozreview-review
Comment on attachment 8784869 [details]
Bug 1280947 - Correct argument to event.sendEvent;

https://reviewboard.mozilla.org/r/74176/#review72148
Attachment #8784869 - Flags: review?(dburns) → review+

Comment 13

3 years ago
mozreview-review
Comment on attachment 8784870 [details]
Bug 1280947 - Add event.change for dispatching DOM change events;

https://reviewboard.mozilla.org/r/74178/#review72150

::: testing/marionette/event.js:1336
(Diff revision 1)
>  
>  event.input = function(el, modifiers = {}, opts = {}) {
>    return event.sendEvent("input", el, modifiers, opts);
>  };
> +
> +event.change = function(el, modifiers = {}, opts = {}) {

This appears to be duplicate of lines 1328-1330

Comment 14

3 years ago
mozreview-review
Comment on attachment 8784871 [details]
Bug 1280947 - Dispatch DOM change event on appending file to input;

https://reviewboard.mozilla.org/r/74180/#review72152
Attachment #8784871 - Flags: review?(dburns) → review+
Assignee

Comment 15

3 years ago
mozreview-review-reply
Comment on attachment 8784870 [details]
Bug 1280947 - Add event.change for dispatching DOM change events;

https://reviewboard.mozilla.org/r/74178/#review72150

> This appears to be duplicate of lines 1328-1330

Oh, oops.
Comment hidden (mozreview-request)
Assignee

Updated

3 years ago
Attachment #8784870 - Attachment is obsolete: true
Attachment #8784870 - Flags: review?(dburns)
Comment hidden (mozreview-request)

Comment 18

3 years ago
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/264c30a316b8
Improve names of JSON marshaling methods in Marionette client; r=automatedtester
https://hg.mozilla.org/integration/autoland/rev/12b83f85ecfe
Support tuples for script arguments; r=automatedtester
https://hg.mozilla.org/integration/autoland/rev/79da2701e6d9
Remove dead File object construction code; r=automatedtester
https://hg.mozilla.org/integration/autoland/rev/3e33306995e3
Correct argument to event.sendEvent; r=automatedtester
https://hg.mozilla.org/integration/autoland/rev/4ecaeb81b71e
Dispatch DOM change event on appending file to input; r=automatedtester
Assignee

Comment 20

3 years ago
Test only changes.
Whiteboard: [checkin-needed-aurora][checkin-needed-beta]
Whiteboard: [checkin-needed-aurora][checkin-needed-beta]
David, do you know who could help with this? Thanks
Flags: needinfo?(dburns)
Assignee

Comment 25

3 years ago
It appears this depends on bug 1290966 to be uplifted first.  I’ve requested uplift for it.
Depends on: 1290966
Flags: needinfo?(dburns)
Flags: needinfo?(ato)
Assignee

Comment 26

3 years ago
Sheriffs: Please uplift bug 1290966 first, which should address earlier test failures on Aurora and Beta.  This patch series also consists of only test-only changes.
Whiteboard: [checkin-needed-aurora][checkin-needed-beta]
Whiteboard: [checkin-needed-aurora][checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.