Closed Bug 1281092 Opened 5 years ago Closed 3 years ago

Crash in `anonymous namespace''::NameResolver::resolve

Categories

(Core :: JavaScript Engine: JIT, defect, P3)

Unspecified
Windows
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox47 --- affected
firefox48 --- affected
firefox49 --- affected
firefox-esr45 --- affected
firefox50 --- affected
firefox51 --- affected
firefox-esr52 --- affected
firefox56 --- affected
firefox57 --- affected

People

(Reporter: ting, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-ca3247b3-93a4-49f8-91fb-24d512160619.
=============================================================
#16 on 20160619 Windows Nightly, 6 crashes from single installation. But there are 347 reports with this signature, which worth a bug.
(In reply to Ting-Yu Chou [:ting] from comment #1)
> #16 on 20160619 Windows Nightly, 6 crashes from single installation. 

indeed https://crash-stats.mozilla.com/signature/?product=Firefox&version=50.0a1&signature=%60anonymous%20namespace%27%27%3A%3ANameResolver%3A%3Aresolve&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&page=1

> But there are 347 reports with this signature, which worth a bug.

Thanks for reporting, but it's really just a large cross section of various versions, and ~200 crashes for a release version is a tiny amount, which seems unlikely to be worth tracking without steps to reproduce.  Do you have steps to reproduce?
Firefox	47.0	197	57.4%	193
Firefox	48.0b1	46	13.4%	45
Firefox	43.0.1	9	2.6%	8
Firefox	48.0b2	9	2.6%	9

(In reply to Ting-Yu Chou [:ting] from comment #0)
> This bug was filed from the Socorro interface and is 
> report bp-ca3247b3-93a4-49f8-91fb-24d512160619.
> =============================================================

 0 	xul.dll	`anonymous namespace'::NameResolver::resolve	js/src/frontend/NameFunctions.cpp:774
1 	xul.dll	`anonymous namespace'::NameResolver::resolve	js/src/frontend/NameFunctions.cpp:702
2 	xul.dll	`anonymous namespace'::NameResolver::resolve	js/src/frontend/NameFunctions.cpp:702
3 	xul.dll	`anonymous namespace'::NameResolver::resolve	js/src/frontend/NameFunctions.cpp:432
4 	xul.dll	`anonymous namespace'::NameResolver::resolve	js/src/frontend/NameFunctions.cpp:702
5 	xul.dll	js::frontend::NameFunctions(js::ExclusiveContext*, js::frontend::ParseNode*)	js/src/frontend/NameFunctions.cpp:839
6 	xul.dll	BytecodeCompiler::prepareAndEmitTree(js::frontend::ParseNode**)	js/src/frontend/BytecodeCompiler.cpp:348
7 	xul.dll	BytecodeCompiler::compileScript(JS::Handle<JSObject*>, JS::Handle<JSScript*>)	js/src/frontend/BytecodeCompiler.cpp:539
8 	xul.dll	js::frontend::CompileScript(js::ExclusiveContext*, js::LifoAlloc*, JS::Handle<JSObject*>, JS::Handle<js::StaticScope*>, JS::Handle<JSScript*>, JS::ReadOnlyCompileOptions const&, JS::SourceBufferHolder&, JSString*, js::SourceCompressionTask*, js::ScriptSourceObject**)	js/src/frontend/BytecodeCompiler.cpp:742
9 	xul.dll	js::ScriptParseTask::parse()	js/src/vm/HelperThreads.cpp:275
10 	xul.dll	js::HelperThread::handleParseWorkload()	js/src/vm/HelperThreads.cpp:1560
11 	xul.dll	js::HelperThread::threadLoop()	js/src/vm/HelperThreads.cpp:1750
Flags: needinfo?(janus926)
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #2)
> Thanks for reporting, but it's really just a large cross section of various
> versions, and ~200 crashes for a release version is a tiny amount, which
> seems unlikely to be worth tracking without steps to reproduce.  Do you have
> steps to reproduce?

No, unfortunately.

The number of crashes actually is far more than that, sorry I didn't explain it clearly but the default search on crash-stats is a week. So if I search for the signature from 2016-01-01 then there are 6299 crashes. And from the graph [1], the number of crashes per day is dozens. I don't know if this is still a relative tiny number...

[1] https://crash-stats.mozilla.com/signature/?date=%3E%3D2016-01-01&product=Firefox&signature=%60anonymous%20namespace%27%27%3A%3ANameResolver%3A%3Aresolve#graphs
Flags: needinfo?(janus926)
Crash volume for signature '`anonymous namespace''::NameResolver::resolve':
 - nightly (version 50): 8 crashes from 2016-06-06.
 - aurora  (version 49): 15 crashes from 2016-06-07.
 - beta    (version 48): 468 crashes from 2016-06-06.
 - release (version 47): 1248 crashes from 2016-05-31.
 - esr     (version 45): 34 crashes from 2016-04-07.

Crash volume on the last weeks:
             Week N-1   Week N-2   Week N-3   Week N-4   Week N-5   Week N-6   Week N-7
 - nightly          1          0          0          0          0          6          1
 - aurora           6          0          1          0          3          1          2
 - beta            88         84         46         76         61         66         12
 - release        189        175        177        181        203        167         65
 - esr              5          1          3          4          6          3          2

Affected platform: Windows
(In reply to Ting-Yu Chou [:ting] from comment #3)
> (In reply to Wayne Mery (:wsmwk, NI for questions) from comment #2)
> > Thanks for reporting, but it's really just a large cross section of various
> > versions, and ~200 crashes for a release version is a tiny amount, which
> > seems unlikely to be worth tracking without steps to reproduce.  Do you have
> > steps to reproduce?
> 
> No, unfortunately.
> 
> The number of crashes actually is far more than that, sorry I didn't explain
> it clearly but the default search on crash-stats is a week. So if I search
> for the signature from 2016-01-01 then there are 6299 crashes. And from the
> graph [1], the number of crashes per day is dozens. I don't know if this is
> still a relative tiny number...
> 
> [1]
> https://crash-stats.mozilla.com/signature/?date=%3E%3D2016-01-
> 01&product=Firefox&signature=%60anonymous%20namespace%27%27%3A%3ANameResolver
> %3A%3Aresolve#graphs

yes, current ~50 per week is tiny, compared for example to the crash signature ranked #300 for version 47
https://crash-stats.mozilla.com/topcrashers/?product=Firefox&version=47.0&_facets_size=300
Crash volume for signature '`anonymous namespace''::NameResolver::resolve':
 - nightly (version 51): 2 crashes from 2016-08-01.
 - aurora  (version 50): 6 crashes from 2016-08-01.
 - beta    (version 49): 216 crashes from 2016-08-02.
 - release (version 48): 203 crashes from 2016-07-25.
 - esr     (version 45): 44 crashes from 2016-05-02.

Crash volume on the last weeks (Week N is from 08-22 to 08-28):
            W. N-1  W. N-2  W. N-3
 - nightly       0       0       2
 - aurora        0       3       1
 - beta         92      40      30
 - release      77      57      31
 - esr           3       1       2

Affected platform: Windows

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly
 - aurora  #1152     #617
 - beta    #250      #86
 - release #307      #167
 - esr     #1372
This probably went away with the frontend rewrite, but that should be verified.
Priority: -- → P3
Still an issue in v56 and v57.

https://crash-stats.mozilla.com/report/index/d6d5a4b2-99aa-47d8-9a9a-b6e371171028 from https://twitter.com/markthecard/status/924289945996492800 "@firefox My browser is now constantly crashing and restarting. Used to be best browser around but now take up too much memory and crashes all the time."

57.0b12	1
57.0b11	3
57.0b9	1
56.0.2	7
56.0.1	13
56.0	10

in the last week.
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
See Also: → 1503374
You need to log in before you can comment on or make changes to this bug.