If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

LDAP AB search won't return more than 100 results (ignores config setting)

VERIFIED DUPLICATE of bug 116984

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED DUPLICATE of bug 116984
16 years ago
13 years ago

People

(Reporter: Daniel Zirin, Assigned: racham)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020221
BuildID:    2002022103

The LDAP address book search won't return more than 100 results from a LDAP
directory that has been configured to allow more than 100 query answers returned.

Reproducible: Always
Steps to Reproduce:
1.Goto Edit/Prefs Mail&News/Addressing preference display and click "Edit
Directories"
2.Add a new directory entry and in the Advanced tab, make sure the "Don't return
more than" field contains a value over 100 (I'm using 1000).
3.Make sure the directory server you're pointing at has been configured to allow
returning more than 100 responses to any given search (most LDAP server configs
default to only return 100, so step is important)
4.Restart Mozilla (because of another bug where the AB doesn't recognize
preference changes until the restart)
5.Use Tasks/Address-Book to display address book with new Directory
6.Click/highlight/select the directory name you added above
7.In the search field, enter a search string that will return a large number of
answers (like the letter "a")
8.The status line at the bottom of the window for the address book will report
how many results are returned (it stops at either 99 or 100 regardless of the
value you used in step 3 above)

Actual Results:  Only 99 or 100 results are returned no matter what the
preference has been set to.

Expected Results:  Should return more than 100 up the the desired limit
specified in the Mozilla advance preference tab it the target LDAP server has
been configured to allow the request.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 116984 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: nbaca → yulian

Updated

16 years ago
Status: RESOLVED → VERIFIED

Comment 2

16 years ago
Verifiied as dup
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.