Closed Bug 1281728 Opened 4 years ago Closed 4 years ago

Ghost windows with Adblock Plus

Categories

(WebExtensions :: General, defect)

x86_64
Windows 10
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: speciesx, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [MemShrink])

Attachments

(1 file)

213.97 KB, application/x-gzip
Details
Attached file memory-report.json.gz
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

After a while 30-60 min (depending on amount of visited pages) memory consumption grows up to 1.5-2GB and firefox start lagging. Closing all tabs except one, don't decrease the memory consumption.

I can reproduce this with and without Add-ons.
Keywords: regression
regression range would be great.

Could you perhaps create GC/CC logs (initially just concise) and send to me? The logs may contain urls and other possibly privacy sensitive data.
Whiteboard: [MemShrink]
Are you using devtools?  There are some known leaks triggered by devtools at the moment.
(In reply to Olli Pettay [:smaug] (high review load, please consider other reviewers) from comment #1)
> regression range would be great.
> 
> Could you perhaps create GC/CC logs (initially just concise) and send to me?
> The logs may contain urls and other possibly privacy sensitive data.

https://www.dropbox.com/s/kit0rpzmrf3coim/GC_CC%20logs.7z?dl=0

(In reply to Ben Kelly [:bkelly] from comment #2)
> Are you using devtools?  There are some known leaks triggered by devtools at
> the moment.

no.
I'm experiencing this too, since one/two weeks. (will try to narrow the regression-range somewhat tomorrow).

in my current session(~5h) i have:
1,242.66 MB (100.0%) -- explicit
├────686.77 MB (55.27%) -- window-objects
│    ├──566.06 MB (45.55%) -- top(none)
│    │  ├──491.66 MB (39.56%) ++ ghost
│    │  └───74.40 MB (05.99%) ++ detached
│    ├───62.41 MB (05.02%) ++ (9 tiny)


131 (100.0%) -- ghost-windows

most of them are tabs closed hours ago and/or tabs opened in private windows(all closed).
Matthias, do you have any addons enabled?  I also open/close private windows frequently and got leaks due to a simple addon.
Flags: needinfo?(mozilla)
Add-ons like 'Element Hiding Helper für Adblock Plus' cause memory leaks.
Yes I am using some addons(Adblock Plus, HTTP Header Mangler, YouTube Plus). My addon-selection has not changed for quite some time(many months).

I am wondering why closed tabs(especially those in private windows) are not discarded when the window is closed?
Flags: needinfo?(mozilla)
SpeciesX, initially you indicated "I can reproduce this with and without Add-ons" but in comment 6 you indicate Adblock Plus caused the leak. Can you still reproduce without add-ons?
Flags: needinfo?(speciesx)
(In reply to Eric Rahm [:erahm] from comment #8)
> SpeciesX, initially you indicated "I can reproduce this with and without
> Add-ons" but in comment 6 you indicate Adblock Plus caused the leak. Can you
> still reproduce without add-ons?

I'm no longer able to reproduce this without add-ons. I've already disabled 'Element Hiding Helper für Adblock Plus' weeks ago, currently Adblock Plus is the reason for my ghost windows.
Flags: needinfo?(speciesx)
Same here, disabling ABP fixes it.

Filed a bug here: https://issues.adblockplus.org/ticket/4203

I guess we can close this bug.
Resolving as INVALID - this was indeed a regression in Adblock Plus, affecting only 2.7.3.4184-beta development build. This issue has been resolved today.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
It seems that Adblock Plus 2.8.2 still has the bug: Bug 1326095
Hi guys what do you think we should do here, reopen this one and mark bug 1326095 as duplicate after this?
Component: DOM → Add-ons
Product: Core → Tech Evangelism
Version: 48 Branch → Trunk
(In reply to ovidiu boca[:Ovidiu] from comment #13)
> Hi guys what do you think we should do here, reopen this one and mark bug
> 1326095 as duplicate after this?

It does
Summary: many ghost windows → Ghost windows with Adblock Plus
(In reply to ovidiu boca[:Ovidiu] from comment #13)
> Hi guys what do you think we should do here, reopen this one and mark bug
> 1326095 as duplicate after this?

It doesn't matter too much. Really, this needs a bug in the ABP bug tracker more than it needs a bugzilla bug.
The new bug might be the same issue, or it might be a new issue. I don't know.
Definitely not the same issue, rather some other kind of memory leak. Either way, I'm looking into it.
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
You need to log in before you can comment on or make changes to this bug.