Tests must be forced to run in en_US

RESOLVED FIXED

Status

()

Firefox for iOS
Build & Test
RESOLVED FIXED
a year ago
2 months ago

People

(Reporter: fluffyemily, Assigned: st3fan)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios10.0)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

a year ago
STR 

Set similator locale to US and langauge to English
run tests
see SearchEngineTests pass
Set simulator locale to any other language/locale
run tests
see SearchEngineTests -> testDefaultEngineOnStartup, testIncludesExpectedEngines & testOrderedEngines fail
(Reporter)

Comment 1

a year ago
Created attachment 8764657 [details] [review]
Pull request

passing in correct locale as arg to tests in schemes for FennecUnitTests, Fennec CI and Fennec
Attachment #8764657 - Flags: review?(sleroux)
Attachment #8764657 - Flags: review?(sleroux) → review+
(Reporter)

Updated

a year ago
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Comment 2

2 months ago
Reopening this because this was set to es_US instead of en_US.
Status: RESOLVED → REOPENED
tracking-fxios: --- → 10.0
Resolution: FIXED → ---
(Assignee)

Updated

2 months ago
Summary: Search Engine Tests fail when simulator locale is not en_US & language is not English → Tests must be forced to run in en_US
(Assignee)

Comment 3

2 months ago
Created attachment 8913752 [details] [review]
PR https://github.com/mozilla-mobile/firefox-ios/pull/3235

This patch makes sure that all the tests are run in the simulator as en-US.
Attachment #8764657 - Attachment is obsolete: true
Attachment #8913752 - Flags: review?(gkeeley)
(Assignee)

Updated

2 months ago
Assignee: etoop → sarentz

Updated

2 months ago
Attachment #8913752 - Flags: review?(gkeeley) → review+

Comment 4

2 months ago
landed master and 10.
Status: REOPENED → RESOLVED
Last Resolved: a year ago2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.