sans serif japanese fonts do not work in messenger

VERIFIED DUPLICATE of bug 95227

Status

SeaMonkey
MailNews: Message Display
--
minor
VERIFIED DUPLICATE of bug 95227
16 years ago
13 years ago

People

(Reporter: jg, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205
BuildID:    

The problem is that Japanese emails make my system use a Serif latin font.
Sometimes I can get it to display a normal sans serif font and other times I get
the horid one.
It really does look bad, thats why I would like to get something "nice" like
Helvetica to display correctly.
Serif appears to be used no matter what I set in Preferences. Its hard to pin
down where the problem is, but i have seen it siince i changed to 0.97 build

I get emails with headers like
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-2022-jp"
Content-Transfer-Encoding: 7bit

so the Charset is correctly selected for me by Mozilla Messenger.

These are the fonts avaialable in Prefereces for Japanese Fonts. I've looked at
them all in KDE Advanced editor and they all are sans serif it appears.

wanatanbe looks the best, as the Japanese looks italic in wadalab.

jis-fixed-jisx0208, 1983-0
misc-fixed-jisx0208, 1983-0
wadalab-gothic-jisx0208, 1983-0
wanatanbe-mincho-jisx0208, 1983-0

Composition is sometimes in Sans serif and sometimes in the Serif Times style
one. EG if i create in UTF8 mode and send japanese as that it displays fine

Reproducible: Sometimes
Steps to Reproduce:
1.get an email in japanese.
2.reply to it
3.see the fonts are allways serif

Actual Results:  Horrible serif times fonts

Updated

16 years ago
QA Contact: esther → ji

Comment 1

16 years ago
I don't see this problem by using the latest build. Reporter, could you please
try the latest nightly build to see if the problem still exists?
Keywords: intl
(Reporter)

Comment 2

16 years ago
OK,

I just created a fresh profile in build 2002022700 and the problem still exists


by default the Japanese font is jis-fixed-jisx0208, 1983-0 after a new install
but actually the font being used to display is wadalab-gothic-jisx0208, 1983-0


It seems that its always a Serif font even though I have configured to to use
sans serif for variable width fonts.

The one font that does "work" is misc-fixed-jisx0208, 1983-0, but this font
looks horid.

In unicode utf8 display the font used is what ever I specify, and then it uses
another font for the japanese characters that are not in the helvetica or
whatever I have setup.

So to summarise I would like to be able to have the same display as UTF-8 which
is currently a helvetica style font but this displays japanese very "nicely" in
a similar sans serif font. Not like the minimal set of japanese fonts available
in the Prefercens section.

This should be possible IMO, any thoughts ji?

>------- Additional Comment #1 From ji@netscape.com 2002-02-28 11:48 ------
>I don't see this problem by using the latest build. Reporter, could you please
>try the latest nightly build to see if the problem still exists?

(Reporter)

Comment 3

16 years ago
Created attachment 72734 [details]
illustrates the display using misc-fixed-jisx0208 font, even though this is not the ideal solution for japanese
(Reporter)

Comment 4

16 years ago
Created attachment 72735 [details]
illustrates how utf-8 japanese emails appear, this is a much "nicer" font for the ascii characters, adobe-helvetica

This would be the desired font for Japanese charset as well, as it uses
helvetica for the ascii and another fonts for the japanese.
JG

Comment 5

16 years ago
CC'ed to Brian.

Comment 6

16 years ago
JG, are you talking about the default fonts we use for Japanese display on
linux? Now it's currently set to serif, considering there are some linux
systems, like RH6.2, which doesn't have sans serif fonts, I think this setting
is right. And on a system which does have sans serif fonts, like RH7.2, I can
set sans serif fonts for Japanese mail display, the changing of the font use is
reflected in Mail, I have no problem with that.
(Reporter)

Comment 7

16 years ago
Hi Ji,

the problem is that utf8 japanese compostion and mail display comes out in a
nice helvetica font for latin and a similar sans serif font for japanese.

however email that is defined as japanese does not have font options to use
hevetica  and thus looks rather bad as I have to display in a worse sans serif
font, the following are the only fonts available in the japanese font section.

jis-fixed-jisx0208, 1983-0
misc-fixed-jisx0208, 1983-0
wadalab-gothic-jisx0208, 1983-0
wanatanbe-mincho-jisx0208, 1983-0


the solution would be too allow the same fonts to be specified as in utf8, but
as with utf8 when japense apears it does not use the hevetica and it uses
another sans serif style font for the japanse characters

please see the screen shots.

bascially the japanese fonts are restricted but the utf8 is not, this is what i
would like to use.

let me know if this exaplains it well enough?

JG

Comment 8

16 years ago
Summary of this bug (it is difficult to understand for someone passing by...)

The reporter says:
> I get emails with headers like
> MIME-Version: 1.0
> Content-Type: text/plain;
>        charset="iso-2022-jp"
[...]
> In unicode utf8 display the font used is what ever I specify, and then it uses
> another font for the japanese characters that are not in the helvetica or
> whatever I have setup.
[...]

SUMMARY:
The problem is that composition is in charset=utf8 and the UI allows the user 
to set a nice font for that. But reception is in charset="iso-2022-jp", and the 
user don't know how to set a font for that.

WHAT TO DO:
The back-end has been improved but the UI is still lagging behind, it is hoped 
that bug 95227 (actually, the work is in bug 61883) will allow the user to 
persist individual fonts (rather than just picking a default of "serif" all the 
time).

In the meantime, since you said that "wanatanbe looks the best", you can 
manually add this to your user.js:

user_pref("font.name.variable.ja", "wanatanbe-mincho-jisx0208.1983-0");

*** This bug has been marked as a duplicate of 95227 ***

*** This bug has been marked as a duplicate of 95227 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
Marked it as verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.