Clear Downloads button can't to clear downloading items

RESOLVED DUPLICATE of bug 1280799

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 1280799
2 years ago
2 years ago

People

(Reporter: liakha, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8765054 [details]
bug-dl-list.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

I've download several files, then i clicked on the "download list" shortcut and the window appear.


Actual results:

I want to clear my download list but I can't : the button on the top of the window is disabled, and same trouble when I right click and want to choose this action.

Once both download are done, I can clear it. I know before i was able to clear the list even if some file were still downloaded : only completed download were removed.


Expected results:

The button shouldn't be disabled and I should be able to clear my download list even if all download aren't done (and remove only the finished download)
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Updated

2 years ago
Component: Untriaged → Downloads Panel

Updated

2 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Downloads Panel → Bookmarks & History
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 1

2 years ago
After https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=09f4968d5f42&tochange=9696d1c4b3ba [Fx38], the button is properly disabled. Before that, the button has no effect and will be disabled when clicked.
Summary: "clear the download list" button staying disabled → Clear Downloads button can't to clear downloading items
Whiteboard: [DUPEME]
That would be bug 1280799
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: [DUPEME]
Duplicate of bug: 1280799
You need to log in before you can comment on or make changes to this bug.