Japanese Search words not properly converted

RESOLVED DUPLICATE of bug 119825

Status

SeaMonkey
Location Bar
RESOLVED DUPLICATE of bug 119825
17 years ago
10 years ago

People

(Reporter: Daniel Nakasone, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

When a Japanese word is searched typing the word in the URL box and using the
"Search Button" the word is not properly converted then the search engine can't
get the proper results.



Reproducible: Always
Steps to Reproduce:
1.Type a Japanese word in the URL box 
2.Push Search Button in the Right of the URL Box or in the combo box drop down 


Actual Results:  I get the results page but the search key is not properly
converted.

The result URL is:
http://www.google.com/search?q=%3F%3F&sourceid=mozilla-search

Expected Results:  It should be:

http://www.google.com/search?q=%8A%BF%8E%9A&sourceid=mozilla-search


When I type a word "KANJI" in japanese the result URL is:

http://www.google.com/search?q=%3F%3F&sourceid=mozilla-search

It should be:

http://www.google.com/search?q=%8A%BF%8E%9A&sourceid=mozilla-search

because typing the same word directly to the search engine home page get the
good results using this URL:

http://www.google.com/search?hl=ja&q=%8A%BF%8E%9A&btnG=Google+%8C%9F%8D%F5&lr=

The same problems occur in Windows 2000 v.2002020406.

Changing the search engine to Netscape the problem persists.

I tried in Spanish but it works OK in Spanish letters if the setting of language
is default to Spanish.

Comment 1

17 years ago
->url bar
Assignee: trudelle → hewitt
Component: XP Apps → URL Bar
QA Contact: sairuh → claudius

Comment 2

16 years ago
Daniel, are you still seeing this in current builds? (Mozilla 1.0 or 1.1alpha or
newer).
Whiteboard: pending
(Reporter)

Comment 3

16 years ago
Hello 
I try it in Windows 2000 and Mozilla 1.0 v.2002053012 looks OK
In Linux and Mozilla 1.0 v.2002052918 it's still getting the same problem。
still in 1.1beta?

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 119825 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: pending
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.