Closed Bug 1282869 (webext-port-google-dictionary) Opened 5 years ago Closed 4 years ago

Enable Google Dictionary extension to work with Firefox

Categories

(WebExtensions :: Compatibility, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mattw, Unassigned)

References

Details

(Whiteboard: [popular chrome extensions]triaged)

Firefox testing link: https://addons.allizom.org/en-US/firefox/addon/google-dictionary-ica-test/

Chrome store link: https://chrome.google.com/webstore/detail/fromdoctopdf/mallpejgeafdahhflmliiahjdpgbegpk

Manifest Errors:
- Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
- Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
- Loading extension 'null': Reading manifest: Error processing options_page: An unexpected property was found in the WebExtension manifest.
- Please specify whether you want browser_style or not in your browser_action options.
- Signature Verification Error: the signature on this .jar archive is invalid because the certificate used to sign this file has an unrecognized issuer.

Running time errors:
- TypeError: PopupNotifications.getNotification(...) is null
- chrome.runtime.onMessageExternal is undefined
- TypeError: gapi.client is undefined
Depends on: 1258360
(In reply to Matthew Wein [:mattw] from comment #0)
> 
> Chrome store link:
> https://chrome.google.com/webstore/detail/fromdoctopdf/
> mallpejgeafdahhflmliiahjdpgbegpk

The correct Chrome store link is: https://chrome.google.com/webstore/detail/google-dictionary-by-goog/mgijmajocgfcbeboacabfgobmjgjcoja
Component: WebExtensions: Untriaged → WebExtensions: Compatibility
Priority: -- → P5
There are no blocking bugs left on this, so I'm going to mark this as resolved fixed in that it should now be possible based on the APIs. Although I note that we'll not likely implement gapi.client.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.