view-source works:not. Shows directory listing (if content is generated?)

RESOLVED DUPLICATE of bug 55583

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 55583
16 years ago
14 years ago

People

(Reporter: Torgny Rasmark, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Javascript sends PHP4-generated content to frame in other window. When trying to
view frame-source, a (partly scrambled) directory listing is shown.
Apache runs on Solaris.
When trying to duplicate the function om my Linux box there is no directory
listing but instead the message:
<br>
<b>Fatal error</b>:  input in flex scanner failed in <b>/export/htdocs/DUGA</b>
on line <b>1</b><br>

Of course I have not checked all platforms but
The error is the same whether Mozilla (0.9.8) runs on MacOS X, Win2000 or linux
(Mandrake 8.1)
Saving frame-content works fine.
Unfortunately there'll be no use in exposing the URL since this here environment
is shut off from the world. I am working on a simplistic version of the script
that will demonstrate the bug.
This should be a dupe of bug 55583

Please reopen if you disagree

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
This bug is said to be a dupe of 55583. I can't see why since 55583 is about
showing original page source (use cached source) while 128298 is about not
showing source at all. Instead it shows a directory listing (of base target I
guess) which is intrusionwise potentially dangerous.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
The reason this happens is that we refetch the source from the server which then
shows us the source of the directory listing page instead of the page that was
shown in the frame.  This bug would not be present if we did not re-request the
document from the server.


*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.