window.location.reload(); does not perform correctly

VERIFIED DUPLICATE of bug 46845

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 46845
16 years ago
16 years ago

People

(Reporter: LJ Wong, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.8+) Gecko/20020227
BuildID:    2002022703

window.location.reload() does not reload input fields if values have been
entered into the input fields.

Reproducible: Always
Steps to Reproduce:
1. Create a html file with a form that has a text field and a reload button
2. Enter the page and type something into the text field
3. Push reload button

Actual Results:  The page is reloaded but the value that you entered into the
field before reloading is still in the input field

Expected Results:  The page is reloaded with an empty text input field
Duplicate of "Form elements don't reset upon reloading page"

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Boris: thanks again!

Verified duplicate. Paul, you have been cc'ed on the other bug -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.