Regression: Invalid top-tab tab count counter indicator specified whilst closing and opening multiple tabs

VERIFIED FIXED

Status

()

VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: aaronmt, Assigned: tlacroix)

Tracking

({regression})

unspecified
Other
iOS
regression

Firefox Tracking Flags

(fxios-v6.0 verified, fxios6.0+)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Currently on Beta 62ac8a, whilst closing multiple tabs, the tab count indicator specifies an invalid value.

=> Hit new tab a bunch of times
=> Start closing tabs

10 -> 9 -> 1 -> 8 -> 1 -> 7 -> 1, etc
(Reporter)

Comment 1

2 years ago
The same behaviour is shown whilst opening a bunch of new tabs too, look at the indicator while doing so.
Summary: Regression: Invalid top-tab tab count counter indicator specified whilst closing multiple tabs → Regression: Invalid top-tab tab count counter indicator specified whilst closing and opening multiple tabs
(Reporter)

Updated

2 years ago
Blocks: 1278667
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1282956
(Assignee)

Updated

2 years ago
Assignee: nobody → tlacroix
Comment on attachment 8766400 [details] [review]
https://github.com/mozilla/firefox-ios/pull/1969

Works pretty well!
Attachment #8766400 - Flags: review?(sleroux) → review+
master 74df88f7c2bc2153f9b1b96391d0f4fa172a919a
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-fxios-v5.0: affected → ---
status-fxios-v6.0: --- → fixed
Resolution: --- → FIXED
tracking-fxios: ? → 6.0+
Verifying as fix on master 1bc8bb71f.
Status: RESOLVED → VERIFIED
status-fxios-v6.0: fixed → verified
You need to log in before you can comment on or make changes to this bug.