Support Outlook as a mailto handler

RESOLVED DUPLICATE of bug 1307550

Status

()

RESOLVED DUPLICATE of bug 1307550
2 years ago
2 years ago

People

(Reporter: osunick, Assigned: maurya1985)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(platform-rel +, fxios6.0+)

Details

(Whiteboard: [good first bug][platform-rel-Microsoft][platform-rel-Outlook])

(Reporter)

Description

2 years ago
Partly because Outlook supports Firefox for links, I use Outlook as my main email client in iOS and have only one email account set up in Mail.app. Unfortunately, when I click an email link in Fx, it opens the default mail client where I don't have the account I want set up. Would feel good to return the favor and give users a sense of what a more open iOS could look like.
I'd use this.
Hardware: Other → All
See Also: → bug 1282929

Updated

2 years ago
Whiteboard: [good first bug]
(Assignee)

Updated

2 years ago
Assignee: nobody → maurya1985
Status: NEW → ASSIGNED
From what I understand, this can't be done with public APIs (and why I still keep a personal email address in Mail.app for this scenario). We'd need to write our own library or use something like http://libmailcore.com/
I asked some of the Outlook team, and got a pointer to Outlook's protocol handler:

https://gist.github.com/aurelienp/071031fe630105518e86

In particular:

---
Compose Email

ms-outlook://emails/new

Compose a new email message. Should open on top of the current view if possible to avoid interrupting any user actions in progress.

Optional Query Parameters:

    from => <upn:servertype>. Defaults to default sending email account.
    to => <emailaddress>,<emailaddress>,.... Defaults to no recipients.
    cc => <emailaddress>,<emailaddress>,.... Defaults to no cc.
    bcc => <emailaddress>,<emailaddress>,.... Defaults to no bcc.
    subject => <text>. Defaults to empty subject.
    body => <text>. Defaults to empty body. The account signature is appended to the body.
---


So if I crack open Settings in Firefox and pick "Outlook", we should turn:

  mailto:?to=foo@bar.com,baz@noo.com&subject=mailto%20with%20examples&body=http://en.wikipedia.org/wiki/Mailto

into

  ms-outlook://emails/new?to=foo@bar.com,baz@noo.com&subject=mailto%20with%20examples&body=http://en.wikipedia.org/wiki/Mailto

and throw it at the OS. I tested this from Safari and it worked.

The main work item is in deciding how we want to present the choice of email application to the user in Settings. Outlook itself could serve as inspiration here.

Robin, do you have an opinion on that?
(Reporter)

Comment 4

2 years ago
I think one approach may be to detect which alternative mail clients are already installed and if outlook is installed, have a picker show up to give the user a choice that they can choose to keep persistent. Similar to how intents are presented in Android.
I thin if we are indeed able to detect other mail apps (I thought that was some sort of security/permissions parameter set by Apple? I could be wrong.) then we should include at least the top 5 or so of the top mail apps to support. Why not?
Robin is correct: there is an OS limitation on `canOpenURL` to prevent apps from sniffing which other apps are installed. You get 50 distinct schemes to try, lifetime.

We can burn one of those permanent slots on each possible mail handler if we wish, but this limit, alongside the need to compute the target URL for each, is why the trend seems to be to just hard-code a drop-down menu somewhere (cf Slack, Outlook).
platform-rel: --- → ?
Whiteboard: [good first bug] → [good first bug][platform-rel-Microsoft][platform-rel-Outlook]

Updated

2 years ago
platform-rel: ? → +

Updated

2 years ago
tracking-fxios: --- → ?

Updated

2 years ago
Rank: 60

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1307550
It's supported now :)
tracking-fxios: ? → 6.0+
You need to log in before you can comment on or make changes to this bug.