Closed Bug 1283227 Opened 5 years ago Closed 5 years ago

Firefox is misinterpreting system proxy exception rules that contain dashes

Categories

(Core :: Networking, defect)

47 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1258977

People

(Reporter: david_r_nielsen, Unassigned)

Details

(Whiteboard: [necko-active])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36

Steps to reproduce:

Firefox 47.01 configured to use system proxy settings. System proxy configured to use enterprise's corporate proxy with several proxy exception rules. Navigated to a URL containing a dash. 

E.g. www.abc-something.com.

Proxy exception list contains *.something.com



There is a proxy 


Actual results:

Received a timeout error

* after removing the proxy exception rule *.something.com the page loaded as expected. When the rule was re-added the timeout error continued.

** Without altering the proxy exception list the site loads as expected in Internet Explorer and Chrome.


Expected results:

Page should load
Component: Untriaged → Networking
Product: Firefox → Core
I have no idea what proxy software are you using.  The "Proxy exception list" is something implemented in Firefox or on your proxy?

Also, www.abc-something.com doesn't match *.something.com.   www-abc.something.com would.
Flags: needinfo?(david_r_nielsen)
Assignee: nobody → honzab.moz
Whiteboard: [necko-active]
@Honza Bambas - I am using Windows 7. The proxy exception list is configured in my browser settings. 

Open Internet Explorer -> Tools -> Internet Options -> Connections -> LAN Settings -> Advanced.

Proxy exceptions are specified in the text area below "Do not use proxy server for addresses beginning with:"

I agree www.abc-something.com should not match *.something.com. In Internet Explorer and Chrome it does not match that proxy exception rule. In Firefox www.abc-something.com does seem to match *.something.com.

Firefox, Internet Explorer, and Chrome are all using the same proxy exception rules, but Firefox seems to be interpreting them differently. At least for proxy exception rules containing dashes.
^^^ comment 2.
Flags: needinfo?(david_r_nielsen)
Nightly 50 (20160717030211).  Windows 10 (I no longer posses Win7)

I followed steps from comment 2.  I have a squid proxy that denies access to anything (just as a test the load goes through that proxy).  Under Internet Explorer -> Tools -> Internet Options -> Connections -> LAN Settings I've set this proxy to be used, under Advanced as being used for all protocols.  In Firefox settings, I switched to Use System Proxy settings.

- I tried to visit a web site "http://www.steps-to-make-your-own-website.com/hyphen-in-domain.html"
- for exception "*.website.com" -> load goes via proxy (expected)
- for exception "*website.com" -> load goes directly (expected)


So, for me this WFM on Nightly on Windows 10.
Assignee: honzab.moz → nobody
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Sorry I didn't notice this bug, which was fixed in bug 1258977
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1258977
You need to log in before you can comment on or make changes to this bug.