No way to cancel or remove right click menu once called

RESOLVED DUPLICATE of bug 95790

Status

()

Core
XUL
P2
normal
RESOLVED DUPLICATE of bug 95790
17 years ago
10 years ago

People

(Reporter: vossman, Assigned: dcone (gone))

Tracking

({testcase})

Trunk
mozilla1.3alpha
PowerPC
Mac OS X
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    20020215

Sometimes, I call up the right click menu, but decide to cancel the request I
usually click of the screen. The menu is perminately set in the foreground even
above other programs.

But when I right click then go to a different window the right click menu will
not go away UNLESS I select one of the option.

Typically I have to cancel using the reload option, which can cause problem if
you are accessing a page with scripts.

Reproducible: Sometimes
Steps to Reproduce:
1. right-click
2. go to a different window without selecting an option
3.

Actual Results:  it is tempermental

Expected Results:  A great way to fix this would be to have a expiration time or
maybe a cancel option within the right click menu

Comment 1

17 years ago
Works for me on 0.9.9. If the context menu hangs around it always destroys
itself when I switch back to the window it belongs to. Reporter, can you still
observe this problem on the latest (0.9.9) milestone or a recent nightly? If not
I propose to mark this as WFM.
(Reporter)

Comment 2

16 years ago
Problem occurs on the webpage (took awhile to isolate):

http://pages.ebay.com/search/items/search.html

It happens after:
1) selecting an option with left click and hold
2) scrolling down (to computers)
3) then click the right mouse button and releasing right mouse button

The problem now occurs everytime.

It lasts even if I switch programs and is always on top. 

It is usually when I have enter a lot of data and do not want to leave the page
without clicking on a submit button. 

(using Mozilla 0.9.9 release, build 2002031005)

vossman

Comment 3

16 years ago
WFM using RC1.
(Reporter)

Comment 4

16 years ago
Still does not work!!!

It is even worse now. On the bug submission page you can get it going. List on
any list (e.g. Product) select one of the options, but instead of using the
left-click use the right-click (or Ctl-left click). The menu WILL NOT go away. 

In mozilla 0.9.9 you could at least select 'Select All' a harmless option. Now
in Mozilla 1.0rc1, I am stuck selecting reload the page (yuck, especially if you
been filling out a huge form, now I have to lose all my data).

This is a user error, but should be addressed.

As mentioned using Mozilla 1.0rc1 (build 2002041712)

Does not work.

neil

Comment 5

16 years ago
vossman, can you reproduce the problem using a new Mozilla user profile?
Summary: no way to cancel or remove right click menu once called → No way to cancel or remove right click menu once called

Comment 6

16 years ago
unable to reproduce this problem with 1.0 or 1.1alpha builds on OS X. Reporter,
are you still seeing this (please test a new build and a new profile)?
Whiteboard: pending

Comment 7

16 years ago
*** Bug 131872 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
I was able to reproduce this with a click and hold on a form. Reassigning to the
correct (or better) component and setting status to New.
Assignee: mpt → rods
Component: User Interface Design → HTML Form Controls
QA Contact: zach → tpreston
Whiteboard: pending

Comment 9

16 years ago
Really marking Confirmed for Asa (drat that bugzilla bug).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 10

16 years ago
Sorry I've been so removed on this problem, but it is still occuring. I have
managed to live with it by selecting one of the options everytime my finger
slips. This may be a function of my new mouse. I bought a 2-button+scroll
logitech mouse and I am unable to test the results on a regular mouse. (Mozilla 1.0)

vossman

Comment 11

16 years ago
-->
Assignee: rods → dcone
(Assignee)

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → mozilla1.3alpha

Comment 12

16 years ago
Reproduced in 1/08/03 Mac OSX Trunk build. Minimised test case attached. 
Keywords: testcase

Comment 13

16 years ago
Created attachment 111195 [details]
Minimised testcase

Comment 14

16 years ago
I see this behavior using these steps:
http://pages.ebay.com/search/items/search.html

It happens after:
1) selecting an option with left click and hold
2) scrolling down (to computers)
3) then click the right mouse button and releasing right mouse button

Mac OS X trunk build 2003011108

Comment 15

16 years ago
XP toolkit
Component: Layout: Form Controls → XP Toolkit/Widgets: Menus

Comment 16

16 years ago

*** This bug has been marked as a duplicate of 95790 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: tpreston → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.