[Remote Control] There are more than five remote controllers can be paired

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mlien, Assigned: chunmin)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.6 fixed)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
[Testing Steps]
0. Fennec and TV connect to the same domain
1. Pair more than 5 remote controllers

[Expected result]
The upper bound number should be 5

[Actual result]
It's able to pair 6 remote controllers

[Build Info]
Environment: 2.6 Nexus Player
gaia:
https://github.com/mozilla-b2g/gaia/commit/508825d1599d6596292e15789181568d00dd4acf
gecko:
https://github.com/mozilla-b2g/gecko-b2g/commit/49b98aa3b415380cc7a021d740b242894654245a

Fennec add-on:
https://github.com/ChunMinChang/fennec-fxos-tv/commit/48bee4df266fe08e19c81e1d8aa3d4fa8b3da6c2

Comment 1

2 years ago
Hi Eric,
Could you check this issue?
Thanks.
Flags: needinfo?(etsai)
(Assignee)

Comment 2

2 years ago
Hi Eric,

The third parameter of |nsIServerSocket.init()| is the maximum length the queue of "pending" connections may grow to[0]. I am not sure whether the alive connection counts. 

Could the connection can be limited in |onSocketAccepted|? Could we only allow the connection when |this._connections.size| is lower than 5?



[0] https://dxr.mozilla.org/mozilla-central/source/netwerk/base/nsIServerSocket.idl#54
(Assignee)

Comment 3

2 years ago
Created attachment 8768300 [details] [review]
Allow only 5 connections

Hi SC,
Could you help to review this?
Attachment #8768300 - Flags: review?(schien)
Comment on attachment 8768300 [details] [review]
Allow only 5 connections

r+'ed with my comment addressed.
Attachment #8768300 - Flags: review?(schien) → review+
(Assignee)

Comment 5

2 years ago
Comment on attachment 8768300 [details] [review]
Allow only 5 connections

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8768300 - Flags: approval-gaia-v2.6?(jocheng)
(Assignee)

Updated

2 years ago
Assignee: nobody → cchang

Updated

2 years ago
blocking-b2g: 2.6? → 2.6+

Comment 6

2 years ago
Comment on attachment 8768300 [details] [review]
Allow only 5 connections

Approve for TV 2.6
Attachment #8768300 - Flags: approval-gaia-v2.6?(jocheng) → approval-gaia-v2.6+
https://github.com/mozilla-b2g/gecko-b2g/commit/b7f962788a7fa3fc8e49a33a4b4e7799730a3937
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-b2g-v2.6: --- → fixed
Resolution: --- → FIXED
Flags: needinfo?(etsai)
You need to log in before you can comment on or make changes to this bug.