If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

gbif.org applet does not load

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED INVALID
16 years ago
7 years ago

People

(Reporter: Les Gasser, Assigned: Joshua Xia)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020207
BuildID:    2002020712

When viewing gbif.org page and clicking a button
that is a java applet, Mozilla immediately
crashes, and the talkback facility
doesn't come up. 

Reproducible: Always
Steps to Reproduce:
1. Point mozilla to "http://www.gbif.org/"

2. Click on the button at the left titled
 "About GBIF". I believe this is a Java applet.

3. Mozilla immediately crashes, and the talkback facility
doesn't come up. 


Actual Results:  Mozilla immediately crashed and the talkback facility did
not come up. 

Expected Results:  Open a new page as usual.

Comment 1

16 years ago
wfm using build 2002022808 on Linux + JRE 1.4.0-b92.

bug only shows on Linux. Java is involved. FrontPage generated page with
fphover.class.

Known sun's jdk 1.3 problem with fphover applet.

=> Dupe of 57372.

reporter: Please upgrade to jre 1.3.1 or 1.4 (1.4 is better).
(Latest 1.3.1 may also have no problem - please try appletviewer
 on testcase from bug 57372 to verify)

*** This bug has been marked as a duplicate of 57372 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Component: Browser-General → OJI
Keywords: crash
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Olivier, merci de ton message.  

I had actually been using the Java 1.3.1 plugin. 

With the Java(TM) Plug-in 1.4.0-b92 the www.gbif.org page does not
fully load and init the fphover.class applets - so I can't tell
whether clicking on them crashes mozilla in the same way. Rather than
displaying buttons, the gbif.org page now just displays broken applet
panels. See below for Java Console output. The current behavior
clearly isn't right.

I tried pointing at all the testcase URLs in bug #57372 and they
worked fine. I also tried many of the testcases in other bug reports
that were mentioned as duplicates of #57372, and the ones I tried also
seemed to work fine - i.e. fphover.class applet did not seem to be
causing problems in them. So it would seem something else is
happening with respect to the gbif.org page.

From the About Plugins window 

 Java(TM) Plug-in 1.4.0-b92
 File name: /usr/local/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so
 Java(TM) Plug-in1.4.0

 Default Plugin
 File name: /home/gasser/Software/Mozilla/Mozilla9.8/plugins/libnullplugin.so
 The default plugin handles plugin data for mimetypes and extensions 
  that are not specified and facilitates downloading of new plugins.

Here is the relevant backtrace from the Java Console window:

load: class fphover.class not found.
java.lang.ClassNotFoundException: fphover.class
	at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:151)
	at sun.plugin.security.PluginClassLoader.findClass(PluginClassLoader.java:189)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:112)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:262)
	at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:478)
	at sun.applet.AppletPanel.createApplet(AppletPanel.java:548)
	at sun.plugin.AppletViewer.createApplet(AppletViewer.java:1621)
	at sun.applet.AppletPanel.runLoader(AppletPanel.java:477)
	at sun.applet.AppletPanel.run(AppletPanel.java:290)
	at java.lang.Thread.run(Thread.java:536)
Caused by: java.io.IOException: open HTTP connection failed.
	at sun.applet.AppletClassLoader.getBytes(AppletClassLoader.java:224)
	at sun.applet.AppletClassLoader.access$100(AppletClassLoader.java:40)
	at sun.applet.AppletClassLoader$1.run(AppletClassLoader.java:141)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:138)
	... 10 more

-- Les
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
confirming using build 2002030803 on Win2k + JRE 1.4.0.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash → hang

Comment 4

16 years ago
Crash/hang here is known jre 1.3 problem. Updating the summary.

Reporter:
  Please try to open java console and set trace level to 5 before visiting the
page. 
Please post console output here.
Keywords: hang
Summary: gbif.org applet crashes mizilla → gbif.org applet does not load

Comment 5

16 years ago
Well, i am able to reproduce this. 
However, i am not quite sure it is really bug.

Applet is created with following 
    <applet code="fphover.class" codebase="../_fpclass/" width="140"
height="30">

But the URL of original document is 
  http://www.gbif.org/

Therefore plugin tries to load 
  http://www.gbif.org/../_fpclass/fphover.class
that is obviously missing.

The only thing that prevent me from closing this bug as INVALID 
is the fact applet was load with 1.3. However, i think this was because 
java plugin had normilized urls internally (and as sideeffect 
not balanced "../" was removed). 

Comment 6

16 years ago
really moving
Assignee: asa → joe.chou
QA Contact: doronr → pmac

Updated

15 years ago
QA Contact: pmac → petersen
(Assignee)

Comment 7

15 years ago
reassign to me
Assignee: joe.chou → joshua.xia
(Assignee)

Comment 8

15 years ago
can't reproduce
Status: NEW → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → INVALID

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.