Cannot set SSL IMAP to port 143

RESOLVED DUPLICATE of bug 134238

Status

RESOLVED DUPLICATE of bug 134238
17 years ago
10 years ago

People

(Reporter: nate, Assigned: mscott)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have a rather odd imap server setup - the imap-ssl server is running on port
143 insted of 993. I realise that this is not how you are supposed to have it
setup - port 143 is for non-ssl - but that's how mine is. I opened "mail/news",
 clicked on "me@my.email.address" in the left "name" pane. Then selected "view
settings for this account." I then clicked on "server settings" for the account.
 I replaced "993" with "143" in the "port" box. I have the "Use SSL" box
selected as well. Hit "ok" button, configuration box goes away. Click on "Inbox"
in left pain. Wirrs for a while. Connection times out. Look at the settings
again - it's still at 993. You can also immideatly click on "settings" again
after "ok" as well as quitting mozilla completly right after "ok," then looking
at the settings. I do not have a non-ssl IMAP server to test if you can change
the port with a non-imap server.
(Reporter)

Comment 1

17 years ago
I did some more testing. It appears that when you check the "SSL" checkbox, it
changes the port from its current setting to 993. This is fine. The problem is
that when you press "ok" it appears to see that you have the "SSL" box checked
and sets the port to 993, disregarding the fact that you changed it after you
checked the "SSL" box! That is you check "USE SSL", the port text-input field
changes to 993. You type a number (such as setting it back to "143" due to my
odd IMAP setup...) into the box, replacing the 993. It stays fine. Press ok. Try
and read your mail - it fails. Go back to settings and it was magically reset to
993, presumably when the "OK" button was checked...

My lame attempt to fix the problem in source led me to the following part of source:

in /mailnews/imap/src/nsImapService.cpp, the code to get the port does the
following:
NS_IMETHODIMP
nsImapService::GetDefaultServerPort(PRBool isSecure, PRInt32 *aDefaultPort)
{
    nsresult rv = NS_OK;
 
    // Return Secure IMAP Port if secure option chosen i.e., if isSecure is TRUE
    if (isSecure) 
       *aDefaultPort = SECURE_IMAP_PORT; 
    else    
        rv = GetDefaultPort(aDefaultPort);
 
    return rv;
}
which is fine, execpt that in the settings dialog there is no way to change the
SECURE_IMAP_PORT... It's hard-coded in mailnews/imap/public/nsIImapUrl.idl right
at the bottom, along with IMAP_PORT. I guess either the settings dialog box
needs to set SECURE_IMAP_PORT insted of IMAP_PORT when the "use ssl" checkbox is
checked, or there needs to be a second one. I havn't been able to figure out how
the dialog boxes work at all yet so I don't know how to fix it :)

Comment 2

17 years ago
Bug 49164 is related and that bug allows you to set the IMAP port to anything
but port 143. Setting the port to 143 however will change the port back to 993
(using Linux 2002070321).

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: FreeBSD → All
Summary: Cannot change IMAP port → Cannot set SSL IMAP to port 143

Comment 3

16 years ago
This bug has been in here for a while and it is still marked as NEW.  As such,
I'm experiencing the same problem, specifically, my service provider supplies
TLS over port 143.  All attempts to change the SSL port to 143 end with mozilla
resetting the port to 993.

My system is Win2K, Moz 1.1 final (Aug 29th nightly didn't work at all when I
tried it.)

Comment 4

16 years ago
*** Bug 181885 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
*** Bug 156382 has been marked as a duplicate of this bug. ***

Updated

16 years ago
QA Contact: huang → gchan
Seth, is scott even working on Mozilla anymore?

Comment 7

16 years ago
I've written a patch for bug 134238 which would also fix this bug. See bug
134238 comment 7 for a description.

Patch at:
http://bugzilla.mozilla.org/attachment.cgi?id=110664&action=edit

Comment 8

16 years ago
Boris,
I don't think Scott is working on it anymore.
Perhaps we should make it clearer that all back-end mailnews bugs are being
assigned to "nobody"?  ;)
Depends on: 134238

Comment 10

15 years ago
(In reply to comment #6)
> Seth, is scott even working on Mozilla anymore?

Does Thunderbird count as working on Mozilla?  If so, I would say he is still
working on it.  mscott seems to be quite involved in mailnews back-end items
still based on his checkins.  But if mscott is not working on it, dimes to
dollars that bienvenu has it.

Kevin

Product: MailNews → Core

Comment 11

11 years ago
duping based on comment 7
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 134238
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.