Setting textarea via value should reset undo state

RESOLVED DUPLICATE of bug 1358025

Status

()

Core
Editor
P3
normal
RESOLVED DUPLICATE of bug 1358025
2 years ago
6 months ago

People

(Reporter: Aaron Nance, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36

Steps to reproduce:

1. Start with a HTML document with a simple textarea element, something like this: <textarea id="ta"></textarea>
2. Set the value of the using JavaScript, like so document.getELementById( "ta" ).value = "Hi THere";
3. Click in the textarea and press Ctrl-Z (Undo)


Actual results:

The text is undone. 


Expected results:

The text should not be undone after being set via JavaScript. This would be consistent with the behavior in all the other browsers.
(Reporter)

Updated

2 years ago
OS: Unspecified → All
Hardware: Unspecified → All

Updated

2 years ago
Component: Untriaged → Editor
Product: Firefox → Core
Priority: -- → P3

Updated

6 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358025
You need to log in before you can comment on or make changes to this bug.