Closed Bug 1284074 Opened 3 years ago Closed 3 years ago

Intermittent dom/media/tests/mochitest/test_peerConnection_removeThenAddVideoTrackNoBundle.html | application crashed [@ mozilla::layers::TextureClient::SetLastFwdTransactionId(unsigned __int64)]

Categories

(Core :: WebRTC, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed
Blocking Flags:

People

(Reporter: intermittent-bug-filer, Assigned: sotaro)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

backlog: --- → webrtc/webaudio+
Rank: 35
Priority: -- → P3
See Also: → 1283723
See Also: → 1283922
See Also: → 1283951
See Also: → 1283957
Any graphics changes around a week ago that might explain this and the various dupes?
Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(nical.bugzilla)
> Assertion failure: mFwdTransactionId < aTransactionId

The above assertion seems like a false alarm. The assertion needs to be changed. It seems like a potential problem, since Bug 1252835. Bug 1280839 might affect to the ImageBridge's task timing change.
Flags: needinfo?(sotaro.ikeda.g)
Assignee: nobody → sotaro.ikeda.g
(In reply to Ryan VanderMeulen [:RyanVM] from comment #1)
> Any graphics changes around a week ago that might explain this and the
> various dupes?

various dupes also hit the assertion. It seems to be caused by the same cause.
Relax the assertion, since there could be a case that same TextureClient is handled multiple times in one transaction.
Attachment #8771207 - Flags: review?(nical.bugzilla)
Attachment #8771207 - Flags: review?(nical.bugzilla) → review+
Flags: needinfo?(nical.bugzilla)
https://hg.mozilla.org/mozilla-central/rev/bfdd3618b368
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.