[Remote Control] The certificate of TLS for remote-control service will be different after flashing and first rebooting

RESOLVED DUPLICATE of bug 1278767

Status

Firefox OS
Gaia::TV
RESOLVED DUPLICATE of bug 1278767
2 years ago
2 years ago

People

(Reporter: chunmin, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.6 ?)

Details

(Whiteboard: [ft:conndevices])

(Reporter)

Description

2 years ago
The certificate will be used as the TV's identification. It should be a constant after flashing. The certificate after flashing will be |X|. After rebooting, it will be |Y|. And then the certificate will be the constant |Y| no matter how many times it reboots. However, it should be always |X| after flashing.
(Reporter)

Updated

2 years ago
Blocks: 1253245

Updated

2 years ago
Whiteboard: [ft:conndevices]
(Reporter)

Updated

2 years ago
blocking-b2g: --- → 2.6?
status-b2g-v2.6: --- → ?

Updated

2 years ago
blocking-b2g: 2.6? → 2.6+

Comment 1

2 years ago
Hi ChunMin,
Could you please provide a ETA? Thanks
Flags: needinfo?(cchang)
(Reporter)

Comment 2

2 years ago
I haven't got the root cause, but it may be caused by bug 1278767. The TV's certificate will be used as its identification, so if it changes, Fennec can't recognize the TV. Therefore, we will have the following results:

[Steps]
1. Flash TV
2. Pair Fennec and TV
3. Reboot TV
4. Pair Fennec and TV

[Expected result]
The pairing in steps 4 doesn't need to enter the PIN code

[Actual result]
The pairing in steps 4 NEED to enter the PIN code

I'll update the ETA ASAP after founding the root cause.
Flags: needinfo?(cchang)
(Reporter)

Updated

2 years ago
See Also: → bug 1278767
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1278767
You need to log in before you can comment on or make changes to this bug.