Kill all keepalive connections when detected NIC change

RESOLVED WORKSFORME

Status

()

Core
Networking
P2
normal
RESOLVED WORKSFORME
2 years ago
3 months ago

People

(Reporter: timdream, Assigned: bagder)

Tracking

(Blocks: 1 bug, {feature})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 attachment)

For me, the one and only use case (as an user) for "work offline" is to reset the connections when I connect/disconnect VPN. We should not remove that feature before this use case is fulfilled:

STR:

1. Go to some website and find it geoip-blocks me
2. Connect to Mozilla External VPN
3. Reload that website

Expected:

1. Website thinks I am in SJC and I can continue browse it

Actual:

1. When I hit reload, The tab hangs at "Connecting..." and the website can't be reloaded in the instant.

Workaround:

3a. Go to File -> Work offline to turn it on.
3b. Go to File -> Work offline to turn it back off.
3c. Reload the website.

Note:

My other use case (as a developer) is to test AppCache w/o disconnect the Wi-Fi as people often do, but that a separate use case)
(In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment #0)
> For me, the one and only use case (as an user) for "work offline" is to
> reset the connections when I connect/disconnect VPN. We should not remove
> that feature before this use case is fulfilled:


so this should actually work automatically for you without work offline. bagder did that work and is ni'd here.

can you please attach
1] https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging
 showing a case where you detach and reload and the new network config is not reflected
2] your Operating System information

thanks
Flags: needinfo?(daniel)
Flags: needinfo?(timdream)
I've failed to reproduce this bug in the Taipei office and connecting to Mozilla VPN. I don't have a non-Mozilla VPN to simulate what I have encounter at home. Will attempt to reproduce some time later...
Created attachment 8768430 [details]
log.tar.gz

This is tested against latest Nightly:

1. Launch Nightly per instruction on MDN
2. Go to hulu.com
-> Websites loads but with a geo-blocked warning.
3. Connect to Mozilla External VPN
4. Hit reload
-> Getting a Connection timeout page
5. Hit reload again
-> Eventually reloads but it takes a lot of time to show the first page.
6. Hit reload again
-> Websites loads but slower, not sure if there is a problem or because of the VPN latency.

(I had to gzip the files first because the raw file size exceeds Bugzilla file size limit)
Flags: needinfo?(timdream)
Assignee: nobody → daniel
Flags: needinfo?(daniel)
Whiteboard: [necko-active]
(In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment #3)
> 6. Hit reload again
> -> Websites loads but slower, not sure if there is a problem or because of
> the VPN latency.

I might have flipped the "Work offline" menu before this reload. Nonetheless, the problem happens at step 4 and 5 so the log is still valid.
(Assignee)

Updated

11 months ago
See Also: → bug 1321841
I expect this will move to P2 (ie not 57), but if there's a chance this is simple fix it's conceivable it could get uplifted.  Worth having a quick look?
Flags: needinfo?(daniel)
Whiteboard: [necko-active]
Priority: P1 → P2
Whiteboard: [necko-triaged]
(Assignee)

Comment 7

4 months ago
I figure this bug can still be triggered? I'm curious on details on step "2. Connect to Mozilla External VPN". Did you already have the VPN/network interface up before you connected there or did you setup the interface as part of step 2 while Firefox was running?

Also, can you switch on network logging for the "nsNotifyAddr" component as well as the others, as that's the one that'll tell if it detects a network change or not and that's a very useful clue here. I'm puzzled by the lack of network change related log output (like for example there's no "PruneNoTraffic" long entries). It could indicate that Firefox doesn't see any "network change" and that could explain things a bit.
Flags: needinfo?(daniel) → needinfo?(timdream)
(In reply to Daniel Stenberg [:bagder] from comment #7)
> I figure this bug can still be triggered? I'm curious on details on step "2.
> Connect to Mozilla External VPN". Did you already have the VPN/network
> interface up before you connected there or did you setup the interface as
> part of step 2 while Firefox was running?

I already have Tunnelblink running. I simply start the connection at this step.

> Also, can you switch on network logging for the "nsNotifyAddr" component as
> well as the others, as that's the one that'll tell if it detects a network
> change or not and that's a very useful clue here. I'm puzzled by the lack of
> network change related log output (like for example there's no
> "PruneNoTraffic" long entries). It could indicate that Firefox doesn't see
> any "network change" and that could explain things a bit.

I've try to produce the log again but unfortunately Mozilla VPN seens to have some problem today (Tunnelblink complains there are no outbound connection). Keeping ni and maybe I will test this out soon after a reboot.
Depends on: 1409642
I've tested on the latest Nightly and it works, though the first reload took some time.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(timdream)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.