[Remote Control] Touch pad doesn't work while showing browser FTE page

RESOLVED FIXED

Status

Firefox OS
Gaia::TV
P1
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: mlien, Assigned: chunmin)

Tracking

(Blocks: 2 bugs)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.6 fixed)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
[Testing Steps]
0. Fennec and TV connect to the same domain
1. Paired fennec and TV
2. Use remote control's touch pad to close browser FTE page

[Expected result]
Be able to click "Skip" or "Sign in" button to next step

[Actual result]
Touch pad doesn't work

[Build Info]
Environment: 2.6 Nexus Player
gaia:
https://github.com/mozilla-b2g/gaia/commit/efa9514dbd028bbd243246cb94e354d78ccff04b
gecko:
https://github.com/mozilla-b2g/gecko-b2g/commit/a06eefe6445d36934d77accd442ee4ffa14ef19d

Fennec add-on:
https://github.com/ChunMinChang/fennec-fxos-tv/commit/6af33d674a25e92c1fa205ba64a61178de6b26dc

Comment 1

2 years ago
Hi ChunMin, Eric
Could you check this issue?
Flags: needinfo?(etsai)
Flags: needinfo?(cchang)
(Assignee)

Comment 2

2 years ago
The virtual mouse(touch pad) can work to click browser buttons(home, zoom-in, ...), so I think it's gaia's bug. After tracing code in Gaia, I found the FTE page only listen 'keyup' event to handle of button press[0]. Simply add a handling in 'click' case can work for our expectation. I'll add a patch soon.

[0] https://github.com/mozilla-b2g/gaia/blob/26fb1315c57b029eb66cc1421d5df7bbd0d9acb3/shared/js/smart-screen/f_t_e_wizard.js#L205
Flags: needinfo?(cchang)
Created attachment 8767908 [details] [review]
[gaia] ChunMinChang:bug1284417 > mozilla-b2g:v2.6
(Assignee)

Comment 4

2 years ago
Comment on attachment 8767908 [details] [review]
[gaia] ChunMinChang:bug1284417 > mozilla-b2g:v2.6

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:

Hi Rex,
I was wondering if you could help us to fix this issue since I am not familiar with Gaia stuff.
Attachment #8767908 - Flags: review?(rexboy)
Comment on attachment 8767908 [details] [review]
[gaia] ChunMinChang:bug1284417 > mozilla-b2g:v2.6

Looks ok to me but I think it'd be better with a little bit change to reduce repeated code. See my Github comment.
Attachment #8767908 - Flags: review?(rexboy) → review+
But it's up to you to consider my suggestion. If you need help on merging code just ask me. Thanks!
(Assignee)

Comment 7

2 years ago
Comment on attachment 8767908 [details] [review]
[gaia] ChunMinChang:bug1284417 > mozilla-b2g:v2.6

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8767908 - Flags: approval-gaia-v2.6?(jocheng)
(Assignee)

Updated

2 years ago
Assignee: nobody → cchang

Updated

2 years ago
blocking-b2g: 2.6? → 2.6+

Comment 8

2 years ago
Comment on attachment 8767908 [details] [review]
[gaia] ChunMinChang:bug1284417 > mozilla-b2g:v2.6

Approve for TV 2.6
Attachment #8767908 - Flags: approval-gaia-v2.6?(jocheng) → approval-gaia-v2.6+
(Assignee)

Updated

2 years ago
Blocks: 1253245
No longer blocks: 1239346
(Assignee)

Updated

2 years ago
Blocks: 1239346
(Assignee)

Comment 9

2 years ago
Please help to merge to Gaia 2.6. Thx!
Flags: needinfo?(lchang)

Comment 10

2 years ago
Land to v2.6: https://github.com/mozilla-b2g/gaia/commit/ace1cb9e420c432ade14f0829d33ca72c73ecc6c
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(lchang)
Resolution: --- → FIXED

Updated

a year ago
Flags: needinfo?(etsai)

Updated

a year ago
status-b2g-v2.6: --- → fixed
You need to log in before you can comment on or make changes to this bug.