Closed Bug 1284445 Opened 4 years ago Closed 4 years ago

BBC fails to detect Flash Player only with Nightly (50)

Categories

(Core :: Plug-ins, defect)

All
Windows
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox50 --- affected

People

(Reporter: masayuki, Unassigned)

References

()

Details

(Keywords: flashplayer, regression)

BBC's movie news pages fail to detect Flash Player. Therefore, they say "You need to install Flash Player to play this content".

For example:
http://www.bbc.com/news/technology-36704371
http://www.bbc.com/japanese/features-and-analysis-36710962?ocid=bbc-japan-twitterjapan

I cannot reproduce it on Aurora nor Release. So, this is Nightly specific issue. Something around plugin API from JS is changed?

This is reproducible with Windows x86 and x64 builds. I don't know about Mac.
Did the plugin infobar show up informing you that the site tried to use Flash? What you have described is the expected behavior so far, as long as the infobar shows up and you have the option to enable Flash.

But this was also backed out this morning for an unrelated regression.
Flags: needinfo?(masayuki)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #4)
> Did the plugin infobar show up informing you that the site tried to use
> Flash?

No. Otherwise I would not have counted this as a regression.

> What you have described is the expected behavior so far, as long as
> the infobar shows up and you have the option to enable Flash.

"(Click|Tap) here to activate plugin" message or any other means (including but not limited to the infobar) to enable Flash.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #4)
> Did the plugin infobar show up informing you that the site tried to use
> Flash? What you have described is the expected behavior so far, as long as
> the infobar shows up and you have the option to enable Flash.

No, the infobar didn't appear. But it's possible to allow to run Flash Player from the locationbar. Then, reloaded page will detect Flash Player correctly.
Flags: needinfo?(masayuki)
The original bug got backed out again. But Brad can you make sure this is fixed before you land again (or if you need assistance finishing up bug 1186948, talk to Felipe because that team is working on the plugin test pilot support code for FF50).
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(blassey.bugs)
Resolution: --- → WORKSFORME
(In reply to Masayuki Nakano [:masayuki] (Mozilla Japan) from comment #6)
> (In reply to Benjamin Smedberg  [:bsmedberg] from comment #4)
> > Did the plugin infobar show up informing you that the site tried to use
> > Flash? What you have described is the expected behavior so far, as long as
> > the infobar shows up and you have the option to enable Flash.
> 
> No, the infobar didn't appear. But it's possible to allow to run Flash
> Player from the locationbar. Then, reloaded page will detect Flash Player
> correctly.

This is the expected behavior, no?
Flags: needinfo?(blassey.bugs)
I didn't notice I could run Flash from the location bar because there is no notification at all. Is it also expected? There should be an infobar per comment #4.
See comment #9.
Flags: needinfo?(blassey.bugs)
My intention was to show the plugin icon in the location bar when navigator.plugins is queried for flash, but not to show the notification bar unless a plugin element is created. Perhaps its better to err on over-prompting to start though, I can flip that in my updated patch.
Flags: needinfo?(blassey.bugs)
Yeah, I think we should err on over-prompting. By design, the click-to-activate UI always expects something to be visible on the page for clicking. The user research showed that the icon by itself was not enough, even for advanced users who knew what was going on.
You need to log in before you can comment on or make changes to this bug.