UI doesn't escape bold ansi escape sequences in logs

RESOLVED FIXED

Status

Taskcluster
Tools
RESOLVED FIXED
a year ago
5 months ago

People

(Reporter: Brian Anderson, Unassigned)

Tracking

Details

(Reporter)

Description

a year ago
Rust tools output bold colors on the terminal with ansi escape sequences. TC is not interpreting them in its HTML UI and instead displays `(B`.

Example: https://tools.taskcluster.net/task-inspector/#muIC2DJeSbqRXfP2z8b8tg/0
Eli - is this hard to fix?
Component: General → Tools
Flags: needinfo?(eperelman)
I believe this is caused by https://github.com/drudru/ansi_up/issues/29

Comment 3

a year ago
Brian is correct, and looking through the library code, anything with bold escapes aren't given special styling. Also from the README of ansi_up:

> This function only interprets ANSI SGR (Select Graphic Rendition) codes that can be represented in HTML. > For example, cursor movement codes are ignored and hidden from output.

My guess is the regex they are using doesn't include the escape sequences being rendered from the Rust log. Does the Rust log contain characters that are incompatible with ansi_up codes?

https://public-artifacts.taskcluster.net/muIC2DJeSbqRXfP2z8b8tg/0/public/logs/live_backing.log

Regardless, we probably should see if there is a more robust ANSI-to-markup solution out there.
Flags: needinfo?(eperelman)

Comment 4

5 months ago
We have since implemented a new log viewer which address many display problems, and should address this one as well.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.