Cannot add/switch/delete tab from tab list

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mlien, Assigned: danhuang)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.6 fixed)

Details

(Whiteboard: [ft:conndevices])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
[Testing Steps]
1. Launch Browser
2. Invoke tab list
3. Add/Switch/Delete tab

[Expected result]
Add/Switch/Delete tab normally

[Actual result]
Add/Switch/Delete tab doesn't work

[Build Info]
Environment: 2.6 Nexus Player
gaia:
https://github.com/mozilla-b2g/gaia/commit/e8bb381435f869a32b4656ecc050f87fbd66b19e
gecko:
https://github.com/mozilla-b2g/gecko-b2g/commit/a06eefe6445d36934d77accd442ee4ffa14ef19d
(Assignee)

Updated

2 years ago
Assignee: nobody → dhuang
Status: NEW → ASSIGNED
(Assignee)

Comment 1

2 years ago
Hi Mike, I can't reproduce this bug on the lasted v2.6 branch.
It seems all tab operations are work well on mulet.
I think it would be better if you could borrow me the Nexus Player with v2.6 branch.
what do you think?
Flags: needinfo?(mlien)
(Reporter)

Comment 2

2 years ago
Sure, you can come and take it any time when you need it. Simulator can also reproduce this issue, below is the simulator build for firefox nightly on linux.
http://mtbf-10.ateam.tpe1.mozilla.com:8081/view/Smart_TV/job/tv_build_simulator_v26/lastSuccessfulBuild/artifact/
Flags: needinfo?(mlien)
Created attachment 8769586 [details] [review]
[gaia] danhuang1202:v2.6_1284793 > mozilla-b2g:v2.6
(Assignee)

Comment 4

2 years ago
Comment on attachment 8769586 [details] [review]
[gaia] danhuang1202:v2.6_1284793 > mozilla-b2g:v2.6

Please review this patch. This patch update className.contains() to classList.contains(). Thanks.
Attachment #8769586 - Flags: review?(lchang)
Comment on attachment 8769586 [details] [review]
[gaia] danhuang1202:v2.6_1284793 > mozilla-b2g:v2.6

Makes sense! Thanks.
Attachment #8769586 - Flags: review?(lchang) → review+
(Assignee)

Comment 6

2 years ago
Thanks for the review.
Merge in v2.6: https://github.com/mozilla-b2g/gaia/commit/a7cfc9510e209e220dabbb831d50b3853f4fd468
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
blocking-b2g: 2.6? → 2.6+

Comment 7

2 years ago
Hi Dan,
Please raise 2.6 uplift approval.
Thanks
Flags: needinfo?(dhuang)
(Assignee)

Updated

2 years ago
status-b2g-v2.6: --- → fixed
Flags: needinfo?(dhuang)
(Assignee)

Comment 8

2 years ago
Comment on attachment 8769586 [details] [review]
[gaia] danhuang1202:v2.6_1284793 > mozilla-b2g:v2.6

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): TV 2.6
[User impact] if declined: tab operation wouldn't work correctly
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8769586 - Flags: approval-gaia-v2.6?

Comment 9

2 years ago
Comment on attachment 8769586 [details] [review]
[gaia] danhuang1202:v2.6_1284793 > mozilla-b2g:v2.6

Approve for Tv 2.6
Attachment #8769586 - Flags: approval-gaia-v2.6? → approval-gaia-v2.6+
You need to log in before you can comment on or make changes to this bug.