Closed Bug 128503 Opened 18 years ago Closed 17 years ago

quicksearch field behavior in AB window not consistent with mail 3pane window

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.4alpha

People

(Reporter: bugzilla, Assigned: shliang)

References

Details

(Keywords: access, Whiteboard: [adt2][ue2])

Attachments

(2 files)

the behavior of the quicksearch field in the addressbook window differs from the
behavior in the mail 3pane window. tested using 2002.03.01.08 comm bits on linux
rh7.2.

in the mail 3pane, i see the following when using quicksearch:

a. clicking in the field selects the text (if there's a string there already),
usually, but also see bug 126314 for issues there.
b. after typing, then pausing for a bit, the string in the field becomes
highlighted (due to search completing) --see bug 128500 for issues with that.
c. hitting enter after typing a string will select the string.

in comparison, the addressbook window exhibits the following with quicksearch:

a. clicking in the field containing a string only places the cursor --no selection.
b. there is no selection when pausing while typing or after the search is done.
c. there is no selection when hitting enter after typing a string.
reassigning to component owner. 
Assignee: naving → racham
I *think* Seth might have done this.
Trunk build 2002-03-07: WinMe
Reproduced on windows as well.

Adding nsbeta1 to consider for usability reasons. After a search you can tab to
the desired card but after pressing Enter nothing happens.

Workaround: The user can select Edit|Properties to then edit the card.
Keywords: access, nsbeta1
marking nsbeta1-.  When this does get fixed, we won't want 'b'.
Keywords: nsbeta1nsbeta1-
Target Milestone: --- → mozilla1.2
b) should be fixed for QS in both mail and addressbook.

sounds like what's needed for addressbook is:

a. clicking in the field containing a string only places the cursor --no selection.
c. there is no selection when hitting enter after typing a string.

oh, to find time to write the XBL for a timed text input widget to be shared in
threadpane, addressbook, addressbook side bar, select address dialog, subscribe
dialog, etc...
Hardware: PC → All
Blocks: 156960
Keywords: nsbeta1-nsbeta1
Whiteboard: [ue2]
Mail triage team: nsbeta1+/adt2
Keywords: nsbeta1nsbeta1+
Whiteboard: [ue2] → [adt2][ue2]
Reassigning.
Assignee: racham → shliang
Attached patch patchSplinter Review
i was a little confused by the comments, but this patch does a, b, and c for
mail and addressbook quicksearch and should also fix bug 126314
Attachment #114261 - Flags: superreview?(sspitzer)
Attachment #114261 - Flags: review?(cavin)
Comment on attachment 114261 [details] [diff] [review]
patch

r=cavin.
Attachment #114261 - Flags: review?(cavin) → review+
Target Milestone: mozilla1.2alpha → mozilla1.4alpha
Comment on attachment 114261 [details] [diff] [review]
patch

r/sr=sspitzer, except don't check in the abCommon.js fix, that looks like it is
for something else.
Attachment #114261 - Flags: superreview?(sspitzer) → superreview+
marking fixed.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Reopening

Trunk build 2003-03-03: WinXP, Linux RH 8
I think this bug should have fixed items "a" and "c" but not "b" since it was
addressed in bug# 128500.

a. Fixed
b. The fix in bug 128500 is no longer working. Reopening due to this issue.
c. Fixed

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
i misunderstood the comments, thought the text was supposed to be selected
after the pause.
taking that out now
Attachment #116157 - Flags: superreview?(sspitzer)
Attachment #116157 - Flags: review?(cavin)
Comment on attachment 116157 [details] [diff] [review]
taking out item "b"

r/sr=sspitzer, assuming you are just reverting the change, and you've tested
well.

good catch, ninoschka.
Attachment #116157 - Flags: superreview?(sspitzer) → superreview+
oops, not ninoschka, sarah found it.
Comment on attachment 116157 [details] [diff] [review]
taking out item "b"

r=cavin.
Attachment #116157 - Flags: review?(cavin) → review+
reverted changes for b
Status: REOPENED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → FIXED
Trunk build 2003-03-05: Mac 10.1.5, WinxP
Verified Fixed. Items a, b and c all work as expected. Great!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.