Closed Bug 1285236 Opened 3 years ago Closed 3 years ago

for (let button of buttons) doesn't freshly bind to each button for arrow function

Categories

(Core :: JavaScript Engine, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 449811
Tracking Status
firefox47 --- affected
firefox48 --- affected
firefox49 --- affected
firefox50 --- affected

People

(Reporter: mconley, Unassigned)

Details

Attachments

(1 file)

Attached file Manual test case
Not sure I'm using the right terminology in the summary here.

See the attached example - I should be able to click either button and get the label for the button sent to the console. This doesn't appear to work in Firefox - the arrow function in the event handler is only ever invoked with the last button that was in the array.

Tested on Release (Firefox 47) and Nightly (50.0a1 (2016-07-06)), and got the same behaviour.
Attachment #8768775 - Attachment mime type: text/plain → text/html
See bug 449811, this will be fixed when shu lands his big frontend rewrite (bug 1263355).
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449811
You need to log in before you can comment on or make changes to this bug.